<!doctype html><html dir=ltr lang=en class=hydrated data-stencil-build=r7xc6j11><head><meta charset="utf-8">
<title>Capacitor - build cross platform apps with the web</title>
<link rel=modulepreload href="/build/p-db2aa20e.js?v=5299e7a160">
<link rel=modulepreload href="/build/p-12b41941.js?v=7ec2847844">
<link rel=modulepreload href="/build/p-96d0993f.js?v=c1a7fa4ad1">
<link rel=modulepreload href="/build/p-a78e2f5e.js?v=810283f352">
<link rel=modulepreload href="/build/p-77b5b76b.js?v=82cbc9a506">
<link rel=modulepreload href="/build/p-bf7988f8.js?v=547fec1720">
<link rel=modulepreload href="/build/p-183a5ba6.js?v=d514f2dc55">
<link rel=modulepreload href="/build/p-01bddde4.js?v=ca738b3493">
<link rel=modulepreload href="/build/p-82a85041.js?v=04ad91584b">
<link rel=modulepreload href="/build/p-0fb857a3.js?v=52beafeb0e">
<link rel=modulepreload href="/build/p-38653301.js?v=78f0bc5479">
<link rel=modulepreload href="/build/p-71ed7e1f.js?v=2671afbfb9">
<link rel=modulepreload href="/build/p-b82b7eca.js?v=df8cc317b5">
<link rel=modulepreload href="/build/p-6858e647.js?v=058549f3cb">
<link rel=modulepreload href="/build/p-ef1f0d0a.js?v=c6d1720362">
<link rel=modulepreload href="/build/p-49288e77.js?v=8b2ff05def">
<link rel=modulepreload href="/build/p-c4cf8438.js?v=2598881fcd">
<link rel=modulepreload href="/build/p-0dd29348.js?v=4ae3708dd9">
<link rel=modulepreload href="/build/p-6e5eca41.js?v=bdcf1a0a05">
<link rel=modulepreload href="/build/p-ed32109d.js?v=c4df98ff1c">
<script data-m>(function(e,t,a,n,r){e[n]=e[n]||[];e[n].push({"gtm.start":(new Date).getTime(),event:"gtm.js"});var g=t.getElementsByTagName(a)[0],m=t.createElement(a),s=n!="dataLayer"?"&l="+n:"";m.async=true;m.src="https://www.googletagmanager.com/gtm.js?id="+r+s;g.parentNode.insertBefore(m,g)})(window,document,"script","dataLayer","GTM-TKMGCBC");</script>
<meta name=viewport content="width=device-width, minimum-scale=1, initial-scale=1, user-scalable=yes">
<meta name=description content="Build iOS, Android, and Progressive Web Apps with HTML, CSS, and JavaScript">
<meta property=og:type content=website>
<meta property=og:title content="Capacitor: Cross-platform native runtime for web apps">
<meta property=og:description content="Build iOS, Android, and Progressive Web Apps with HTML, CSS, and JavaScript">
<meta property=og:image content="https://capacitorjs.com/assets/img/og.png">
<meta property=og:url content="https://capacitorjs.com">
<meta name=twitter:title content="Capacitor: Cross-platform native runtime for web apps">
<meta name=twitter:description content="Build iOS, Android, and Progressive Web Apps with HTML, CSS, and JavaScript">
<meta name=twitter:image content="https://capacitorjs.com/assets/img/og.png">
<meta name=twitter:creator content=@capacitorjs>
<meta property=og:site_name content="Capacitor: Cross-platform native runtime for web apps">
<meta name=twitter:site content=@capacitorjs>
<meta name=twitter:card content=summary_large_image>
<meta name="format-detection" content="telephone=no">
<meta name="msapplication-tap-highlight" content=no>
<meta name="theme-color" content=#16161d>
<script data-m>navigator.serviceWorker.getRegistrations().then((function(e){for(let r of e){r.unregister()}}));</script>
<script type=module src="/build/site.esm.js?v=4eb84b1053" data-stencil data-resources-url="/build/"
data-stencil-namespace=site></script>
<script nomodule src="/build/site.js?v=b44ace3970" data-stencil></script>
<style sty-id="sc-capacitor-site">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</style>
<style sty-id="sc-site-root">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</style>
<style sty-id="sc-announcement-bar">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</style>
<style sty-id="sc-site-header">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</style>
<style sty-id="sc-landing-page">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</style>
<style sty-id="sc-site-backdrop">.sc-site-backdrop-h{position:fixed;top:0;height:100vh;left:0;right:0;background:rgba(0, 26, 58, 0.08);cursor:pointer;opacity:0;pointer-events:none;-webkit-transition:0.4s opacity, 0.4s visibility step-end;transition:0.4s opacity, 0.4s visibility step-end;visibility:hidden;outline:2px solid rgba(0, 0, 0, 0);z-index:0}.site-backdrop--visible.sc-site-backdrop-h:not(.site-backdrop--mobile-only){opacity:1;pointer-events:all;visibility:visible;-webkit-transition:0.4s opacity, 0.4s visibility step-start;transition:0.4s opacity, 0.4s visibility step-start}@media screen and (max-width: 768px){.site-backdrop--visible.site-backdrop--mobile-only.sc-site-backdrop-h{opacity:1;pointer-events:all;visibility:visible;-webkit-transition:0.4s opacity, 0.4s visibility step-start;transition:0.4s opacity, 0.4s visibility step-start}}</style>
<style sty-id="sc-docs-search">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</style>
<style sty-id="sc-more-button">more-button{height:32px;width:32px}more-button button{height:100%;width:100%;font-size:20px;background:transparent;border:none;outline:none;cursor:pointer;-webkit-transition:opacity 0.2s ease-out;transition:opacity 0.2s ease-out}more-button button ion-icon{color:var(--color, black)}more-button button:hover{opacity:0.4}</style>
<style sty-id="sc-docs-dropdown">.Dropdown{display:inline-block;position:relative;z-index:1;outline:none}.Dropdown-button{-webkit-appearance:none;-moz-appearance:none;appearance:none;background:none;border:none;color:inherit;font-family:inherit;font-size:inherit;font-weight:inherit;line-height:inherit;padding:initial;white-space:nowrap}.Dropdown-button .Dropdown-icon{height:14px;width:22px;fill:#ced6e0}.Dropdown-button .Dropdown-icon+.Dropdown-arrow{margin-left:0px;fill:#ced6e0;vertical-align:2px}.Dropdown:focus,.Dropdown-button:focus{outline:none}.Dropdown-button:hover{cursor:pointer}.Dropdown-arrow{fill:currentColor;height:0.8em;margin-bottom:-0.0875em;width:0.8em;margin-left:0.8em}.Dropdown.is-open .Dropdown-arrow{-webkit-transform:rotate(180deg);transform:rotate(180deg)}.Dropdown-panel{background-color:var(--color-white);border-radius:6px;border:none;-webkit-box-shadow:0px 4px 12px 0px rgba(0, 0, 0, 0.08),
    0px 2px 4px 0px rgba(0, 0, 0, 0.08);box-shadow:0px 4px 12px 0px rgba(0, 0, 0, 0.08),
    0px 2px 4px 0px rgba(0, 0, 0, 0.08);display:none;min-width:100%;overflow:hidden;pointer-events:none;position:absolute;top:100%;visibility:hidden}.Dropdown.is-open .Dropdown-panel{display:initial;pointer-events:auto;visibility:visible}.Dropdown--left .Dropdown-panel{left:0}.Dropdown--right .Dropdown-panel{right:0}.Dropdown--center .Dropdown-panel{left:50%;-webkit-transform:translateX(-50%);transform:translateX(-50%)}.Dropdown-panel a{display:-ms-flexbox;display:flex;-ms-flex-pack:justify;justify-content:space-between;padding:0.5em 1em}.Dropdown-panel svg{height:1em;width:1em;margin-left:4px}@media (hover: hover){.Dropdown-panel a:hover{background-color:rgba(0, 0, 0, 0.025)}}.Dropdown-panel>section{padding:0.5em 0}.Dropdown-panel>section:not(:last-child){border-bottom:solid 1px var(--line-rule-color)}.Dropdown{-ms-flex-item-align:center;align-self:center;color:var(--c-indigo-80)}.Dropdown-button{color:var(--c-indigo-80);padding:10px;-webkit-transition:border-color 100ms ease;transition:border-color 100ms ease}.Dropdown.is-open .Dropdown-button{border-color:var(--line-rule-color)}.Dropdown-panel{min-width:180px}.Dropdown-panel a{display:-ms-flexbox;display:flex;-ms-flex-pack:justify;justify-content:space-between;color:var(--c-indigo-80)}.Dropdown-panel svg{height:1em;width:1em}.Dropdown-panel .Nav-link{margin-left:0;margin-right:0}</style>
<style sty-id="sc-code-snippet">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</style>
<style sty-id="sc-code-tabs">code[class*=language-].sc-code-tabs,pre[class*=language-].sc-code-tabs{color:#ccc;background:none;font-family:Consolas, Monaco, "Andale Mono", "Ubuntu Mono", monospace;font-size:1em;text-align:left;white-space:pre;word-spacing:normal;word-break:normal;word-wrap:normal;line-height:1.5;-moz-tab-size:4;-o-tab-size:4;tab-size:4;-webkit-hyphens:none;-moz-hyphens:none;-ms-hyphens:none;hyphens:none}pre[class*=language-].sc-code-tabs{padding:1em;margin:0.5em 0;overflow:auto}.sc-code-tabs:not(pre)>code[class*=language-].sc-code-tabs,pre[class*=language-].sc-code-tabs{background:#2d2d2d}.sc-code-tabs:not(pre)>code[class*=language-].sc-code-tabs{padding:0.1em;border-radius:0.3em;white-space:normal}.token.comment.sc-code-tabs,.token.block-comment.sc-code-tabs,.token.prolog.sc-code-tabs,.token.doctype.sc-code-tabs,.token.cdata.sc-code-tabs{color:#999}.token.punctuation.sc-code-tabs{color:#ccc}.token.tag.sc-code-tabs,.token.attr-name.sc-code-tabs,.token.namespace.sc-code-tabs,.token.deleted.sc-code-tabs{color:#e2777a}.token.function-name.sc-code-tabs{color:#6196cc}.token.boolean.sc-code-tabs,.token.number.sc-code-tabs,.token.function.sc-code-tabs{color:#f08d49}.token.property.sc-code-tabs,.token.class-name.sc-code-tabs,.token.constant.sc-code-tabs,.token.symbol.sc-code-tabs{color:#f8c555}.token.selector.sc-code-tabs,.token.important.sc-code-tabs,.token.atrule.sc-code-tabs,.token.keyword.sc-code-tabs,.token.builtin.sc-code-tabs{color:#cc99cd}.token.string.sc-code-tabs,.token.char.sc-code-tabs,.token.attr-value.sc-code-tabs,.token.regex.sc-code-tabs,.token.variable.sc-code-tabs{color:#7ec699}.token.operator.sc-code-tabs,.token.entity.sc-code-tabs,.token.url.sc-code-tabs{color:#67cdcc}.token.important.sc-code-tabs,.token.bold.sc-code-tabs{font-weight:bold}.token.italic.sc-code-tabs{font-style:italic}.token.entity.sc-code-tabs{cursor:help}.token.inserted.sc-code-tabs{color:green}.sc-code-tabs-h{display:block;max-width:560px;min-width:0}nav.sc-code-tabs{padding:16px}code-snippet.sc-code-tabs{height:100%}.tabs-wrapper.sc-code-tabs{overflow:auto;position:relative;display:-ms-flexbox;display:flex}.tabs-wrapper.sc-code-tabs button.sc-code-tabs{color:var(--c-indigo-90);font-weight:500;font-size:14px;line-height:100%;letter-spacing:-0.02em;cursor:pointer;background:transparent;border-radius:1000px;padding:10px 12px;height:34px;border:none;font-family:inherit;-webkit-transition:color 0.2s ease-out, opacity 0.2s ease-out;transition:color 0.2s ease-out, opacity 0.2s ease-out}.tabs-wrapper.sc-code-tabs button.sc-code-tabs+button.sc-code-tabs{-webkit-margin-start:6px;margin-inline-start:6px}.tabs-wrapper.sc-code-tabs button.sc-code-tabs:active,.tabs-wrapper.sc-code-tabs button.sc-code-tabs:focus{outline:2px solid rgba(0, 0, 0, 0)}.tabs-wrapper.sc-code-tabs button.sc-code-tabs:hover{opacity:0.7}.tabs-wrapper.sc-code-tabs button.active.sc-code-tabs{color:#fff}.tabs-wrapper.sc-code-tabs button.active.sc-code-tabs:hover{opacity:1}.tabs-wrapper.sc-code-tabs::after{content:"";z-index:-1;background:var(--c-capacitor-blue);position:absolute;left:var(--tab-left);height:34px;width:var(--tab-width);border-radius:1000px;-webkit-transition:width 0.2s cubic-bezier(0.22, 0.62, 0.04, 0.93), left 0.2s cubic-bezier(0.22, 0.62, 0.04, 0.93);transition:width 0.2s cubic-bezier(0.22, 0.62, 0.04, 0.93), left 0.2s cubic-bezier(0.22, 0.62, 0.04, 0.93)}.background.sc-code-tabs{overflow:hidden;border-radius:16px;background:#00233a}.code-wrapper.sc-code-tabs{display:-ms-flexbox;display:flex;background:#00233a;position:relative;left:var(--code-left);-webkit-transition:left 500ms cubic-bezier(0.4, 0, 0.2, 1);transition:left 500ms cubic-bezier(0.4, 0, 0.2, 1)}.code-wrapper.sc-code-tabs article.sc-code-tabs{min-width:100%}</style>
<style sty-id="sc-site-modal">:root{--modal-z-index:1100;--modal-backdrop-z-index:1090;--modal-width:768px;--modal-padding:48px;--modal-border-radius:24px}site-modal{display:block;pointer-events:none;position:fixed;top:0;left:0;bottom:0;right:0;z-index:var(--modal-z-index)}.modal__backdrop{position:fixed;top:0;right:0;bottom:0;left:0;z-index:var(--modal-backdrop-z-index);-webkit-transition:opacity 300ms ease-in-out;transition:opacity 300ms ease-in-out;background-color:#000;opacity:0}.modal__backdrop.in{opacity:0.5}.modal__backdrop.out{opacity:0}.modal__wrap{-webkit-transition:-webkit-transform 300ms cubic-bezier(0.32, 0.72, 0, 1);transition:-webkit-transform 300ms cubic-bezier(0.32, 0.72, 0, 1);transition:transform 300ms cubic-bezier(0.32, 0.72, 0, 1);transition:transform 300ms cubic-bezier(0.32, 0.72, 0, 1), -webkit-transform 300ms cubic-bezier(0.32, 0.72, 0, 1);-webkit-transform:translateY(-120%);transform:translateY(-120%)}.modal__wrap.in{-webkit-transform:translate(0%);transform:translate(0%)}.modal__content{pointer-events:auto;max-width:var(--modal-width);margin:76px auto;background:white;position:relative;border-radius:var(--modal-border-radius)}.modal__content .modal__close-button{position:absolute;top:-10px;right:-10px;background:#fff;color:var(--c-carbon-90);padding:0;text-align:center;border:0;border-radius:100%;height:30px;width:30px;-webkit-box-shadow:var(--elevation-2);box-shadow:var(--elevation-2);outline:0}.modal__content .modal__close-button ion-icon{vertical-align:middle;margin-top:-3px}.modal__body{padding:var(--modal-padding);max-height:calc(100vh - 76px);overflow:auto}.modal__body h1,.modal__body h2,.modal__body h3,.modal__body h4,.modal__body h5{margin-top:0}</style>
<style sty-id="sc-pre-footer">.sc-pre-footer:root{--c-capacitor-blue:#119eff}.sc-pre-footer-h{display:block;position:relative;background:#fff}.squares.sc-pre-footer{position:absolute;display:-ms-flexbox;display:flex;height:100%;width:100%}@media screen and (max-width: 640px){.squares.sc-pre-footer{-ms-flex-direction:column;flex-direction:column}}.squares.sc-pre-footer::before{content:"";-ms-flex-preferred-size:50%;flex-basis:50%;-webkit-border-end:1px solid var(--c-indigo-20);border-inline-end:1px solid var(--c-indigo-20);-webkit-border-before:1px solid var(--c-indigo-20);border-block-start:1px solid var(--c-indigo-20)}.squares.sc-pre-footer::after{content:"";-ms-flex-preferred-size:50%;flex-basis:50%;-webkit-border-before:1px solid var(--c-indigo-20);border-block-start:1px solid var(--c-indigo-20)}.ui-container.sc-pre-footer{position:relative;z-index:1;display:-ms-flexbox;display:flex}@media screen and (max-width: 640px){.ui-container.sc-pre-footer{-ms-flex-direction:column;flex-direction:column}}.ui-container.sc-pre-footer>a.sc-pre-footer{-ms-flex-preferred-size:50%;flex-basis:50%;-webkit-padding-before:var(--space-9);padding-block-start:var(--space-9);-webkit-padding-after:var(--space-9);padding-block-end:var(--space-9)}.ui-container.sc-pre-footer>a.sc-pre-footer svg.sc-pre-footer{-webkit-margin-after:var(--space-5);margin-block-end:var(--space-5)}.ui-container.sc-pre-footer>a.sc-pre-footer:first-of-type{-webkit-padding-end:clamp(32px, 10vw, 88px);padding-inline-end:clamp(32px, 10vw, 88px)}@media screen and (max-width: 640px){.ui-container.sc-pre-footer>a.sc-pre-footer:first-of-type{-webkit-padding-end:0;padding-inline-end:0}}.ui-container.sc-pre-footer>a.sc-pre-footer:last-of-type{-webkit-padding-start:clamp(32px, 10vw, 88px);padding-inline-start:clamp(32px, 10vw, 88px)}@media screen and (max-width: 640px){.ui-container.sc-pre-footer>a.sc-pre-footer:last-of-type{-webkit-padding-start:0;padding-inline-start:0}}</style>
<style sty-id="sc-capacitor-site-footer">:root{--c-capacitor-blue:#119eff}capacitor-site-footer{display:block;-webkit-border-before:1px solid var(--c-indigo-20);border-block-start:1px solid var(--c-indigo-20);-webkit-padding-before:64px;padding-block-start:64px;-webkit-padding-after:72px;padding-block-end:72px;position:relative;background:#fff;border-block-start:1px solid var(--c-indigo-20)}capacitor-site-footer ul{padding:0}capacitor-site-footer .newsletter{display:-ms-flexbox;display:flex;-ms-flex-wrap:wrap;flex-wrap:wrap;-ms-flex-pack:justify;justify-content:space-between;-webkit-margin-after:4rem;margin-block-end:4rem;-webkit-margin-before:-1rem;margin-block-start:-1rem;--h4-color:var(--c-carbon-100);--p4-color:var(--c-indigo-70)}@media (max-width: 767px){capacitor-site-footer .newsletter{-webkit-margin-after:2rem;margin-block-end:2rem}}capacitor-site-footer .newsletter>*{-webkit-margin-before:16px;margin-block-start:16px}capacitor-site-footer .routes-group{display:-ms-flexbox;display:flex;-ms-flex-pack:justify;justify-content:space-between}capacitor-site-footer a.link{color:var(--c-indigo-70);font-weight:normal}capacitor-site-footer .copyright p{font-family:"Inter";color:var(--c-indigo-70);font-size:14px;letter-spacing:-0.02em;line-height:1.6em;margin:0}capacitor-site-footer img.logo{width:106px;margin-bottom:7px}capacitor-site-footer .ui-heading{color:var(--c-carbon-80);margin-bottom:11px}capacitor-site-footer .routes li{list-style-type:none;margin-top:7px;letter-spacing:0}capacitor-site-footer .form-group{-ms-flex-preferred-size:479px;flex-basis:479px}capacitor-site-footer form.hs-form{display:-ms-flexbox;display:flex;-ms-flex-align:start;align-items:flex-start;-ms-flex-wrap:wrap;flex-wrap:wrap;position:relative;-webkit-margin-before:-16px;margin-block-start:-16px}capacitor-site-footer form.hs-form>*{-webkit-margin-before:16px;margin-block-start:16px}capacitor-site-footer form.hs-form li{list-style-type:none}capacitor-site-footer form.hs-form .hs-email{-ms-flex-positive:1;flex-grow:1;max-width:276px}capacitor-site-footer form.hs-form .hs-email label{position:absolute;opacity:0}capacitor-site-footer form.hs-form .input{width:100%;position:relative}capacitor-site-footer form.hs-form .input input{-webkit-padding-start:16px;padding-inline-start:16px;width:calc(100% - 12px);height:48px;border:1px solid #dee3ea;border-radius:var(--radius-2);-webkit-transition:border 0.2s ease-out, -webkit-box-shadow 0.2s ease-out;transition:border 0.2s ease-out, -webkit-box-shadow 0.2s ease-out;transition:border 0.2s ease-out, box-shadow 0.2s ease-out;transition:border 0.2s ease-out, box-shadow 0.2s ease-out, -webkit-box-shadow 0.2s ease-out}capacitor-site-footer form.hs-form .input input::-webkit-input-placeholder{color:#6d6c82;opacity:0.4}capacitor-site-footer form.hs-form .input input::-moz-placeholder{color:#6d6c82;opacity:0.4}capacitor-site-footer form.hs-form .input input:-ms-input-placeholder{color:#6d6c82;opacity:0.4}capacitor-site-footer form.hs-form .input input::-ms-input-placeholder{color:#6d6c82;opacity:0.4}capacitor-site-footer form.hs-form .input input::placeholder{color:#6d6c82;opacity:0.4}capacitor-site-footer form.hs-form .input input:focus{outline:1px solid rgba(0, 0, 0, 0);border:1px solid #3880ff;-webkit-box-shadow:0px 0px 0px 3px #c2d8ff;box-shadow:0px 0px 0px 3px #c2d8ff}capacitor-site-footer form.hs-form .hs-submit input{display:-ms-flexbox;display:flex;-ms-flex-align:center;align-items:center;-ms-flex-pack:center;justify-content:center;cursor:pointer;height:48px;border:none;background:var(--c-capacitor-blue);color:#fff;border-radius:var(--radius-2);font-family:var(--f-family-text);letter-spacing:-0.02em;font-weight:500;font-size:16px;line-height:19px;-webkit-margin-before:0;margin-block-start:0;-webkit-margin-after:0;margin-block-end:0;padding:15px 18px 16px 18px;-webkit-transition:background-color 0.2s ease-out, -webkit-box-shadow 0.2s ease-out;transition:background-color 0.2s ease-out, -webkit-box-shadow 0.2s ease-out;transition:box-shadow 0.2s ease-out, background-color 0.2s ease-out;transition:box-shadow 0.2s ease-out, background-color 0.2s ease-out, -webkit-box-shadow 0.2s ease-out}capacitor-site-footer form.hs-form .hs-submit input:hover{background:#24a7ff;-webkit-box-shadow:none;box-shadow:none}capacitor-site-footer form.hs-form .hs-submit input:active{background:#0090f0}capacitor-site-footer form.hs-form .hs-submit input:focus{outline:1px solid rgba(0, 0, 0, 0);-webkit-box-shadow:0px 0px 0px 3px #c2d8ff;box-shadow:0px 0px 0px 3px #c2d8ff}capacitor-site-footer form.hs-form .hs_error_rollup{position:absolute;top:100%;left:12px;font-size:14px;color:var(--c-red-100);-webkit-margin-before:4px;margin-block-start:4px}</style>
<style sty-id="sc-ion-icon">/*!@:host*/.sc-ion-icon-h{display:inline-block;width:1em;height:1em;contain:strict;fill:currentColor;-webkit-box-sizing:content-box !important;box-sizing:content-box !important}/*!@:host .ionicon*/.sc-ion-icon-h .ionicon.sc-ion-icon{stroke:currentColor}/*!@.ionicon-fill-none*/.ionicon-fill-none.sc-ion-icon{fill:none}/*!@.ionicon-stroke-width*/.ionicon-stroke-width.sc-ion-icon{stroke-width:32px;stroke-width:var(--ionicon-stroke-width, 32px)}/*!@.icon-inner,
.ionicon,
svg*/.icon-inner.sc-ion-icon,.ionicon.sc-ion-icon,svg.sc-ion-icon{display:block;height:100%;width:100%}/*!@:host(.flip-rtl) .icon-inner*/.flip-rtl.sc-ion-icon-h .icon-inner.sc-ion-icon{-webkit-transform:scaleX(-1);transform:scaleX(-1)}/*!@:host(.icon-small)*/.icon-small.sc-ion-icon-h{font-size:18px !important}/*!@:host(.icon-large)*/.icon-large.sc-ion-icon-h{font-size:32px !important}/*!@:host(.ion-color)*/.ion-color.sc-ion-icon-h{color:var(--ion-color-base) !important}/*!@:host(.ion-color-primary)*/.ion-color-primary.sc-ion-icon-h{--ion-color-base:var(--ion-color-primary, #3880ff)}/*!@:host(.ion-color-secondary)*/.ion-color-secondary.sc-ion-icon-h{--ion-color-base:var(--ion-color-secondary, #0cd1e8)}/*!@:host(.ion-color-tertiary)*/.ion-color-tertiary.sc-ion-icon-h{--ion-color-base:var(--ion-color-tertiary, #f4a942)}/*!@:host(.ion-color-success)*/.ion-color-success.sc-ion-icon-h{--ion-color-base:var(--ion-color-success, #10dc60)}/*!@:host(.ion-color-warning)*/.ion-color-warning.sc-ion-icon-h{--ion-color-base:var(--ion-color-warning, #ffce00)}/*!@:host(.ion-color-danger)*/.ion-color-danger.sc-ion-icon-h{--ion-color-base:var(--ion-color-danger, #f14141)}/*!@:host(.ion-color-light)*/.ion-color-light.sc-ion-icon-h{--ion-color-base:var(--ion-color-light, #f4f5f8)}/*!@:host(.ion-color-medium)*/.ion-color-medium.sc-ion-icon-h{--ion-color-base:var(--ion-color-medium, #989aa2)}/*!@:host(.ion-color-dark)*/.ion-color-dark.sc-ion-icon-h{--ion-color-base:var(--ion-color-dark, #222428)}</style>
<style sty-id="sc-hubspot-form">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</style>
<link rel=preload href="/assets/fonts/inter/Inter-variable-ASCII-subset.woff2?v=0dfffed154" as=font
type="font/woff2">
<link rel=preload href="/assets/fonts/eina/eina-01-bold.woff2?v=1f43ca2a15" as=font type="font/woff2">
<link rel=preload href="/assets/fonts/eina/eina-01-semibold.woff2?v=c74a71a18f" as=font type="font/woff2">
<link rel=stylesheet href="/build/site.css?v=899c666ed7">
<link href="https://fonts.googleapis.com/css?family=Roboto+Mono:400,700" rel=stylesheet>
<link rel=manifest href="/manifest.json?v=ef6ebbea45">
<link rel=icon type="image/png" href="/assets/img/favicon.png?v=48ca96a418">
<style>.stencil-router-queue{display:none!important}</style>
<link rel=prefetch href="/docs/page.state.json?v=r7xc6j11" as=fetch>
<link rel=prefetch href="/docs/plugins/page.state.json?v=r7xc6j11" as=fetch>
<link rel=prefetch href="/docs/cli/page.state.json?v=r7xc6j11" as=fetch>
<link rel=prefetch href="/community/page.state.json?v=r7xc6j11" as=fetch>
<link rel=prefetch href="/blog/page.state.json?v=r7xc6j11" as=fetch>
<link rel=prefetch href="/enterprise/page.state.json?v=r7xc6j11" as=fetch>
<link rel=prefetch href="/docs/getting-started/page.state.json?v=r7xc6j11" as=fetch>
<link rel=prefetch href="/cordova/page.state.json?v=r7xc6j11" as=fetch>
<link rel=prefetch href="/docs/apis/page.state.json?v=r7xc6j11" as=fetch>
<link rel=prefetch href="/solution/react/page.state.json?v=r7xc6j11" as=fetch>
<link rel=prefetch href="/solution/angular/page.state.json?v=r7xc6j11" as=fetch>
<link rel=prefetch href="/solution/svelte/page.state.json?v=r7xc6j11" as=fetch>
<link rel=prefetch href="/solution/vue/page.state.json?v=r7xc6j11" as=fetch>
<link rel=prefetch href="/solution/stencil/page.state.json?v=r7xc6j11" as=fetch>
<link rel=canonical href="https://capacitorjs.com/">
</head>
<body>  <noscript><iframe
        src="https://www.googletagmanager.com/ns.html?id=GTM-TKMGCBC"
        height="0"
        width="0"
        style="display: none; visibility: hidden"
      ></iframe></noscript>
 <capacitor-site class=hydrated s-id=1><!--r.1--><site-root class=hydrated c-id=1.0.0.0 s-id=2><!--r.2--><!--o.1.1--><!--s.2.0.0.0.--><div
class="page-theme--light" c-id=1.1.1.0><announcement-bar class="sc-announcement-bar-h sc-announcement-bar-s ui-announcement-bar ui-announcement-bar--default hydrated"
c-id=1.2.2.0 s-id=3 style="--asset-path: url('/assets-announcement-bar/bg-default.png');"><!--r.3--><a
href="https://ionic.io/resources/webinars/getting-started-with-ionic-6-livestream" target=_blank rel=noopener
class="link-wrapper sc-announcement-bar" c-id=3.0.0.0><div class="ui-container sc-announcement-bar" c-id=3.1.1.0><p
class="ui-paragraph ui-paragraph-3 ui-paragraph--body sc-announcement-bar" c-id=3.2.2.0><!--t.3.3.3.0-->Getting started with
<strong class="sc-announcement-bar" c-id=3.4.3.1><!--t.3.5.4.0-->Ionic 6</strong><!--t.3.6.3.2--> livestream</p><button
class="sc-announcement-bar" c-id=3.7.2.1><!--t.3.8.3.0-->Register Now<span class="arrow sc-announcement-bar"
c-id=3.9.3.1><!--t.3.10.4.0--> -&gt;</span></button></div></a></announcement-bar><site-header class="heading-container sc-site-header-h sc-site-header-s theme--light sticky hydrated"
c-id=1.3.2.1 s-id=4><!--r.4--><site-backdrop class="sc-site-header sc-site-backdrop-h sc-site-backdrop-s site-backdrop--mobile-only hydrated"
tabindex="-1" c-id=4.0.0.0 s-id=5><!--r.5--></site-backdrop><header class="sc-site-header" c-id=4.1.0.1><a
href="/" aria-label="homepage link" class="sc-site-header" c-id=4.2.1.0><svg class="capacitor-logo sc-site-header"
width=130 height=24 fill=none xmlns="http://www.w3.org/2000/svg" c-id=4.3.2.0><path d="M55.36 6.03v12.84h-3.22V17.3c-.8 1.17-2.26 1.86-4.08 1.86-3.73 0-5.92-2.99-5.92-6.7 0-3.73 2.19-6.72 5.92-6.72 1.82 0 3.26.69 4.08 1.87V6.04h3.22zM48.8 8.81c-1.94 0-3.17 1.56-3.17 3.64 0 2.09 1.23 3.65 3.17 3.65s3.16-1.56 3.16-3.65c.01-2.08-1.21-3.64-3.16-3.64zM60.1 23.2h-3.49V6.05h3.22v1.57c.8-1.17 2.26-1.87 4.08-1.87 3.73 0 5.92 3 5.92 6.71 0 3.73-2.19 6.71-5.92 6.71a4.73 4.73 0 01-3.8-1.66v5.7zm3.07-7.1c1.94 0 3.17-1.56 3.17-3.65 0-2.08-1.23-3.64-3.17-3.64S60 10.37 60 12.45c0 2.09 1.22 3.65 3.17 3.65zM83.76 6.03v12.84h-3.22V17.3c-.8 1.17-2.26 1.86-4.08 1.86-3.73 0-5.92-2.99-5.92-6.7 0-3.73 2.18-6.72 5.92-6.72 1.82 0 3.26.69 4.08 1.87V6.04h3.22zM77.2 8.81c-1.94 0-3.17 1.56-3.17 3.64 0 2.09 1.23 3.65 3.17 3.65s3.16-1.56 3.16-3.65c.01-2.08-1.21-3.64-3.16-3.64zM37.92 14.16c-.41 1.11-1.45 1.73-2.73 1.73a3.4 3.4 0 01-3.39-3.44 3.4 3.4 0 013.4-3.43c1.27 0 2.27.54 2.72 1.73h3.5a6.12 6.12 0 00-6.23-5c-3.7 0-6.66 3-6.66 6.7 0 3.71 2.95 6.71 6.66 6.71 3.12 0 5.82-2.19 6.24-5h-3.5zM93.86 14.16c-.41 1.11-1.45 1.73-2.73 1.73a3.4 3.4 0 01-3.38-3.44 3.4 3.4 0 013.38-3.43c1.28 0 2.29.54 2.74 1.73h3.5a6.12 6.12 0 00-6.24-5c-3.7 0-6.66 3-6.66 6.7 0 3.71 2.96 6.71 6.66 6.71 3.12 0 5.82-2.19 6.24-5h-3.5zM97.78 2.9c0-1.22.89-2.1 2.11-2.1 1.23 0 2.12.88 2.12 2.1 0 1.23-.89 2.08-2.12 2.08a2.02 2.02 0 01-2.1-2.08zm.37 3.13h3.49v12.84h-3.5V6.03zM102.95 6.03V2.85h3.49v3.18h2.68v2.84h-2.68v10h-3.5V8.79"
fill=#000 class="sc-site-header" c-id=4.4.3.0></path><path fill-rule=evenodd clip-rule=evenodd d="M115.34 15.9a3.44 3.44 0 100-6.89 3.44 3.44 0 000 6.88zm0 3.26a6.71 6.71 0 100-13.42 6.71 6.71 0 000 13.42z"
fill=#000 class="sc-site-header" c-id=4.5.3.1></path><path d="M129.96 9.2s-.36-.07-.67-.07c-2.02 0-3.06 1-3.06 3.36v6.4h-3.46V6.02h3.19V7.7c.46-.76 1.43-1.78 3.59-1.78l.41.03V9.2z"
fill=#000 class="sc-site-header" c-id=4.6.3.2></path><path d="M3.74 5.07L.03 8.8l5.72 5.73L0 20.3 3.7 24l5.76-5.77 5.72 5.73 3.71-3.71L3.74 5.07z"
fill=#53B9FF class="sc-site-header" c-id=4.7.3.3></path><path d="M13.17 14.52l-3.71 3.71 5.72 5.73 3.71-3.71-5.72-5.73z"
fill=#119EFF class="sc-site-header" c-id=4.8.3.4></path><path d="M13.17 14.52l-3.71 3.71 1.43 1.43 2.28-5.14z"
fill=#000 fill-opacity=.2 class="sc-site-header" c-id=4.9.3.5></path><path fill-rule=evenodd clip-rule=evenodd
d="M18.24 9.47L24 3.7 20.29 0l-5.76 5.75L8.8.03 5.1 3.74l15.15 15.18 3.7-3.72-5.7-5.73z" fill=#53B9FF
class="sc-site-header" c-id=4.10.3.6></path><path d="M10.81 9.47l3.72-3.72L8.8.03 5.1 3.74l5.71 5.73z"
fill=#119EFF class="sc-site-header" c-id=4.11.3.7></path><path d="M10.81 9.47l3.72-3.72-1.43-1.42-2.29 5.14z"
fill=#000 fill-opacity=.2 class="sc-site-header" c-id=4.12.3.8></path></svg></a><div class="jobs-wrapper sc-site-header"
c-id=4.13.1.1><a class="jobs sc-site-header" href="https://ionic.io/about/jobs#positions" target=_blank
rel=noopener c-id=4.14.2.0><svg width=12 height=12 fill=none xmlns="http://www.w3.org/2000/svg" class="sparkle sc-site-header"
c-id=4.15.3.0><g clip-path=url(#clip0) fill=#D0FDFF class="sc-site-header" c-id=4.16.4.0><path d="M4.4 2.9a.65.65 0 011.22 0l.8 2.25c.07.18.22.33.4.4l2.25.8a.65.65 0 010 1.22l-2.25.8a.65.65 0 00-.4.4l-.8 2.25a.65.65 0 01-1.22 0l-.8-2.25a.65.65 0 00-.4-.4l-2.25-.8a.65.65 0 010-1.22l2.25-.8c.18-.07.33-.22.4-.4l.8-2.25zM9.04 1.2c.15-.4.72-.4.87 0l.29.81c.04.13.14.23.27.28l.8.29c.41.14.41.72 0 .87l-.8.28a.46.46 0 00-.27.28l-.3.8c-.14.41-.71.41-.86 0l-.29-.8a.46.46 0 00-.28-.28l-.8-.28a.46.46 0 010-.87l.8-.3a.46.46 0 00.28-.27l.29-.8zM1.5.48c.1-.3.5-.3.6 0l.24.65c.03.1.1.16.2.2l.65.23c.29.1.29.5 0 .61l-.65.24c-.1.03-.17.1-.2.2l-.23.65c-.1.28-.51.28-.62 0l-.23-.66a.32.32 0 00-.2-.2l-.65-.23a.32.32 0 010-.6l.65-.24c.1-.04.17-.1.2-.2l.23-.65z"
class="sc-site-header" c-id=4.17.5.0></path></g><defs class="sc-site-header" c-id=4.18.4.1><clipPath id=clip0
class="sc-site-header" c-id=4.19.5.0><path fill=#fff d="M0 0h12v12H0z" class="sc-site-header" c-id=4.20.6.0></path></clipPath></defs></svg><!--t.4.21.3.1-->We're hiring<svg
xmlns="http://www.w3.org/2000/svg" class="ionicon arrow sc-site-header" width=14 height=12 viewBox="0 0 512 512"
c-id=4.22.3.2><title class="sc-site-header" c-id=4.23.4.0><!--t.4.24.5.0-->Arrow Forward</title>
<path fill=none stroke=currentColor stroke-linecap=round stroke-linejoin=round stroke-width=48 d="M268 112l144 144-144 144M392 256H100"
class="sc-site-header" c-id=4.25.4.1></path></svg></a></div><div class="docs-search-wrapper desktop-only sc-site-header"
c-id=4.26.1.2><docs-search class="sc-site-header theme--light hydrated" id="id-07043355910014746" c-id=4.27.2.0
s-id=6><!--r.6--><svg class="search-icon" width=14 height=14 fill=none xmlns="http://www.w3.org/2000/svg"
c-id=6.0.0.0><path d="M13.7854 12.5947L10.6117 9.421a5.8626 5.8626 0 001.1752-3.5276C11.7869 2.6438 9.1431 0 5.8934 0 2.6438 0 0 2.6438 0 5.8934c0 3.2497 2.6438 5.8935 5.8934 5.8935a5.8626 5.8626 0 003.5276-1.1752l3.1737 3.1737a.8436.8436 0 001.1583-.0324.8436.8436 0 00.0324-1.1583zM1.6838 5.8934a4.2096 4.2096 0 114.2096 4.2096 4.2145 4.2145 0 01-4.2096-4.2096z"
fill=#B2BECD c-id=6.1.1.0></path></svg><input id="input-07043355910014746" name=search type=search
autocomplete=off placeholder=Search aria-label=Search required c-id=6.2.0.1 style="visibility: hidden;"><ion-icon
class="close sc-ion-icon-h md hydrated" role=img aria-label=close c-id=6.3.0.2 s-id=7
style="display: none;"><!--r.7--><div class="icon-inner sc-ion-icon" c-id=7.0.0.0></div></ion-icon><site-backdrop class="sc-site-backdrop-h sc-site-backdrop-s site-backdrop--mobile-only hydrated"
tabindex="-1" c-id=6.4.0.3 s-id=8><!--r.8--></site-backdrop></docs-search></div><a href="/docs" class="ui-paragraph-4 sc-site-header"
c-id=4.28.1.3><!--t.4.29.2.0-->Docs</a><a href="/docs/plugins" class="ui-paragraph-4 sc-site-header"
c-id=4.30.1.4><!--t.4.31.2.0-->Plugins</a><a href="/docs/cli" class="ui-paragraph-4 sc-site-header" c-id=4.32.1.5><!--t.4.33.2.0-->CLI</a><div
class="separator desktop-only sc-site-header" c-id=4.34.1.6></div><nav class="routes sc-site-header" c-id=4.35.1.7><div
class="routes__header sc-site-header" c-id=4.36.2.0><a aria-label="homepage link" class="logo-wrapper sc-site-header"
href="/" c-id=4.37.3.0><svg class="capacitor-logo sc-site-header" width=130 height=24 fill=none xmlns="http://www.w3.org/2000/svg"
c-id=4.38.4.0><path d="M55.36 6.03v12.84h-3.22V17.3c-.8 1.17-2.26 1.86-4.08 1.86-3.73 0-5.92-2.99-5.92-6.7 0-3.73 2.19-6.72 5.92-6.72 1.82 0 3.26.69 4.08 1.87V6.04h3.22zM48.8 8.81c-1.94 0-3.17 1.56-3.17 3.64 0 2.09 1.23 3.65 3.17 3.65s3.16-1.56 3.16-3.65c.01-2.08-1.21-3.64-3.16-3.64zM60.1 23.2h-3.49V6.05h3.22v1.57c.8-1.17 2.26-1.87 4.08-1.87 3.73 0 5.92 3 5.92 6.71 0 3.73-2.19 6.71-5.92 6.71a4.73 4.73 0 01-3.8-1.66v5.7zm3.07-7.1c1.94 0 3.17-1.56 3.17-3.65 0-2.08-1.23-3.64-3.17-3.64S60 10.37 60 12.45c0 2.09 1.22 3.65 3.17 3.65zM83.76 6.03v12.84h-3.22V17.3c-.8 1.17-2.26 1.86-4.08 1.86-3.73 0-5.92-2.99-5.92-6.7 0-3.73 2.18-6.72 5.92-6.72 1.82 0 3.26.69 4.08 1.87V6.04h3.22zM77.2 8.81c-1.94 0-3.17 1.56-3.17 3.64 0 2.09 1.23 3.65 3.17 3.65s3.16-1.56 3.16-3.65c.01-2.08-1.21-3.64-3.16-3.64zM37.92 14.16c-.41 1.11-1.45 1.73-2.73 1.73a3.4 3.4 0 01-3.39-3.44 3.4 3.4 0 013.4-3.43c1.27 0 2.27.54 2.72 1.73h3.5a6.12 6.12 0 00-6.23-5c-3.7 0-6.66 3-6.66 6.7 0 3.71 2.95 6.71 6.66 6.71 3.12 0 5.82-2.19 6.24-5h-3.5zM93.86 14.16c-.41 1.11-1.45 1.73-2.73 1.73a3.4 3.4 0 01-3.38-3.44 3.4 3.4 0 013.38-3.43c1.28 0 2.29.54 2.74 1.73h3.5a6.12 6.12 0 00-6.24-5c-3.7 0-6.66 3-6.66 6.7 0 3.71 2.96 6.71 6.66 6.71 3.12 0 5.82-2.19 6.24-5h-3.5zM97.78 2.9c0-1.22.89-2.1 2.11-2.1 1.23 0 2.12.88 2.12 2.1 0 1.23-.89 2.08-2.12 2.08a2.02 2.02 0 01-2.1-2.08zm.37 3.13h3.49v12.84h-3.5V6.03zM102.95 6.03V2.85h3.49v3.18h2.68v2.84h-2.68v10h-3.5V8.79"
fill=#000 class="sc-site-header" c-id=4.39.5.0></path><path fill-rule=evenodd clip-rule=evenodd d="M115.34 15.9a3.44 3.44 0 100-6.89 3.44 3.44 0 000 6.88zm0 3.26a6.71 6.71 0 100-13.42 6.71 6.71 0 000 13.42z"
fill=#000 class="sc-site-header" c-id=4.40.5.1></path><path d="M129.96 9.2s-.36-.07-.67-.07c-2.02 0-3.06 1-3.06 3.36v6.4h-3.46V6.02h3.19V7.7c.46-.76 1.43-1.78 3.59-1.78l.41.03V9.2z"
fill=#000 class="sc-site-header" c-id=4.41.5.2></path><path d="M3.74 5.07L.03 8.8l5.72 5.73L0 20.3 3.7 24l5.76-5.77 5.72 5.73 3.71-3.71L3.74 5.07z"
fill=#53B9FF class="sc-site-header" c-id=4.42.5.3></path><path d="M13.17 14.52l-3.71 3.71 5.72 5.73 3.71-3.71-5.72-5.73z"
fill=#119EFF class="sc-site-header" c-id=4.43.5.4></path><path d="M13.17 14.52l-3.71 3.71 1.43 1.43 2.28-5.14z"
fill=#000 fill-opacity=.2 class="sc-site-header" c-id=4.44.5.5></path><path fill-rule=evenodd clip-rule=evenodd
d="M18.24 9.47L24 3.7 20.29 0l-5.76 5.75L8.8.03 5.1 3.74l15.15 15.18 3.7-3.72-5.7-5.73z" fill=#53B9FF
class="sc-site-header" c-id=4.45.5.6></path><path d="M10.81 9.47l3.72-3.72L8.8.03 5.1 3.74l5.71 5.73z"
fill=#119EFF class="sc-site-header" c-id=4.46.5.7></path><path d="M10.81 9.47l3.72-3.72-1.43-1.42-2.29 5.14z"
fill=#000 fill-opacity=.2 class="sc-site-header" c-id=4.47.5.8></path></svg></a><button class="close sc-site-header"
aria-label=close c-id=4.48.3.1><svg width=10 height=10 fill=none xmlns="http://www.w3.org/2000/svg" class="sc-site-header"
c-id=4.49.4.0><path d="M9 9L1 1M9 1L1 9" stroke=#B2BECD stroke-width=2 stroke-linecap=round
stroke-linejoin=round class="sc-site-header" c-id=4.50.5.0></path></svg></button></div><div class="docs-search-wrapper mobile-only sc-site-header"
c-id=4.51.2.1><docs-search class="sc-site-header theme--light hydrated" id="id-043144808091388875" c-id=4.52.3.0
s-id=9><!--r.9--><svg class="search-icon" width=14 height=14 fill=none xmlns="http://www.w3.org/2000/svg"
c-id=9.0.0.0><path d="M13.7854 12.5947L10.6117 9.421a5.8626 5.8626 0 001.1752-3.5276C11.7869 2.6438 9.1431 0 5.8934 0 2.6438 0 0 2.6438 0 5.8934c0 3.2497 2.6438 5.8935 5.8934 5.8935a5.8626 5.8626 0 003.5276-1.1752l3.1737 3.1737a.8436.8436 0 001.1583-.0324.8436.8436 0 00.0324-1.1583zM1.6838 5.8934a4.2096 4.2096 0 114.2096 4.2096 4.2145 4.2145 0 01-4.2096-4.2096z"
fill=#B2BECD c-id=9.1.1.0></path></svg><input id="input-043144808091388875" name=search type=search
autocomplete=off placeholder=Search aria-label=Search required c-id=9.2.0.1 style="visibility: hidden;"><ion-icon
class="close sc-ion-icon-h md hydrated" role=img aria-label=close c-id=9.3.0.2 s-id=10
style="display: none;"><!--r.10--><div class="icon-inner sc-ion-icon" c-id=10.0.0.0></div></ion-icon><site-backdrop class="sc-site-backdrop-h sc-site-backdrop-s site-backdrop--mobile-only hydrated"
tabindex="-1" c-id=9.4.0.3 s-id=11><!--r.11--></site-backdrop></docs-search></div><a href="/community" class="ui-paragraph-4 sc-site-header"
c-id=4.53.2.2><!--t.4.54.3.0-->Community</a><a href="/blog" class="ui-paragraph-4 sc-site-header" c-id=4.55.2.3><!--t.4.56.3.0-->Blog</a><a
href="/enterprise" class="ui-paragraph-4 sc-site-header" c-id=4.57.2.4><!--t.4.58.3.0-->Enterprise</a></nav><div
class="separator desktop-only sc-site-header" c-id=4.59.1.8></div><more-button class="sc-site-header hydrated"
c-id=4.60.1.9 s-id=12><!--r.12--><button c-id=12.0.0.0><ion-icon class="sc-ion-icon-h md hydrated" role=img
aria-label="ellipsis vertical" c-id=12.1.1.0 s-id=13><!--r.13--><div class="icon-inner sc-ion-icon" c-id=13.0.0.0></div></ion-icon></button></more-button><div
class="ctas sc-site-header" c-id=4.61.1.10><docs-dropdown class="label-sm-only sc-site-header Dropdown Dropdown--right hydrated"
tabindex=0 c-id=4.62.2.0 s-id=14><!--r.14--><!--o.4.63--><button tabindex="-1" class="Dropdown-button"
aria-haspopup=menu aria-expanded=false c-id=14.0.0.0><svg viewBox="0 0 22 14" fill=none class="Dropdown-icon"
c-id=14.1.1.0><path d="M19.3213 13.9999H22.0001L17.039 1.21558H14.2346L9.2832 13.9999H11.8072L13.0064 10.7307H18.1415L19.3213 13.9999ZM15.5014 3.65195H15.6658L17.5613 8.92339H13.5866L15.5014 3.65195Z"
fill=#B2BECD c-id=14.2.2.0></path><path d="M0 1.10938H12.4318L11.5697 3.32812H0V1.10938Z" fill=#B2BECD
c-id=14.3.2.1></path><path fill-rule=evenodd clip-rule=evenodd d="M8.75268 1.11609C8.75268 1.11609 8.75268 1.11712 9.89332 1.11712C11.034 1.11712 11.034 1.11822 11.034 1.11822L11.034 1.11939L11.034 1.12198L11.0339 1.12805L11.0337 1.14382C11.0335 1.15593 11.0332 1.17122 11.0325 1.1896C11.0313 1.22637 11.029 1.27554 11.0248 1.33642C11.0164 1.45817 11.0003 1.62689 10.9695 1.83709C10.9081 2.25748 10.7879 2.84428 10.5533 3.55314C10.083 4.97375 9.15623 6.87412 7.33744 8.89844L7.30893 8.93017L2.7154 13.3124L1.24023 11.7004L5.63338 7.45082C7.21765 5.67868 7.9949 4.05478 8.37789 2.89777C8.57098 2.31443 8.66471 1.84706 8.71016 1.53633C8.73288 1.38097 8.74352 1.2649 8.74847 1.19324C8.75095 1.15741 8.752 1.13272 8.75243 1.11981L8.75272 1.10938L8.7527 1.11094L8.75269 1.11345L8.75268 1.11609Z"
fill=#B2BECD c-id=14.4.2.2></path><rect x=5.5166 width=2.20704 height=1.10937 fill=#B2BECD c-id=14.5.2.3></rect><path
d="M4.17075 7.9686C3.09555 6.69872 2.39593 5.48407 1.94141 4.4375H4.40026C4.76103 5.09472 5.24197 5.81584 5.88345 6.5682L5.93101 6.62398L5.96524 6.67692C5.96787 6.68067 5.97319 6.68816 5.98137 6.69921C6.0017 6.72667 6.03969 6.77615 6.09781 6.8448C6.21395 6.98199 6.41098 7.19635 6.70864 7.46479C7.19301 7.9016 8.18265 8.61127 9.29424 9.23901L8.50109 11.2671C6.94927 10.5044 5.9002 9.71638 5.23489 9.11639C4.86256 8.78062 4.5965 8.49477 4.41706 8.28281C4.32738 8.17688 4.25946 8.08955 4.21081 8.02383C4.19559 8.00327 4.18226 7.98483 4.17075 7.9686Z"
fill=#B2BECD c-id=14.6.2.4></path></svg><svg viewBox="0 0 512 512" class="Dropdown-arrow" c-id=14.7.1.1><path
d="M256 294.1L383 167c9.4-9.4 24.6-9.4 33.9 0s9.3 24.6 0 34L273 345c-9.1 9.1-23.7 9.3-33.1.7L95 201.1c-4.7-4.7-7-10.9-7-17s2.3-12.3 7-17c9.4-9.4 24.6-9.4 33.9 0l127.1 127z"
c-id=14.8.2.0></path></svg></button><div role=menu class="Dropdown-panel" c-id=14.9.0.1><!--s.14.10.1.0.--><section
class="sc-site-header" c-id=4.63.3.0><a href="https://capacitorjs.com/" class="link-active sc-site-header"
c-id=4.64.4.0><!--t.4.65.5.0-->English<svg viewBox="0 0 512 512" width=14 class="sc-site-header" c-id=4.66.5.1><path
d="M186.301 339.893L96 249.461l-32 30.507L186.301 402 448 140.506 416 110z" class="sc-site-header"
c-id=4.67.6.0></path></svg></a><a href="https://capacitorjs.jp/" target=_blank class="sc-site-header"
c-id=4.68.4.1><!--t.4.69.5.0-->日本語</a></section></div></docs-dropdown><a href="https://github.com/ionic-team/capacitor"
target=_blank rel=noopener class="sc-site-header" c-id=4.70.2.1><svg class="social sc-site-header" width=16
height=16 fill=none xmlns="http://www.w3.org/2000/svg" c-id=4.71.3.0><path d="M8 0a8.1 8.1 0 0 0-8 8.2c0 3.63 2.3 6.7 5.47 7.79l.14.01c.3 0 .4-.22.4-.4v-1.4c-.3.06-.57.1-.81.1-1.54 0-1.89-1.2-1.89-1.2-.36-.95-.89-1.2-.89-1.2-.7-.5 0-.5.05-.5.8.06 1.23.84 1.23.84.4.7.94.9 1.41.9.38 0 .72-.12.92-.21.07-.53.28-.9.5-1.1-1.77-.2-3.64-.91-3.64-4.05 0-.9.31-1.63.82-2.2-.08-.21-.35-1.05.08-2.18l.18-.01c.3 0 .94.1 2.02.86a7.5 7.5 0 0 1 4.01 0c1.08-.75 1.73-.86 2.02-.86l.18.01c.44 1.13.16 1.97.08 2.18.5.57.82 1.3.82 2.2 0 3.15-1.87 3.84-3.65 4.04.28.25.54.75.54 1.52l-.01 2.25c0 .2.1.41.4.41l.15-.01A8.19 8.19 0 0 0 16 8.2 8.1 8.1 0 0 0 8 0Z"
fill=#B2BECD class="sc-site-header" c-id=4.72.4.0></path></svg></a><a href="https://ionic.link/discord"
target=_blank rel=noopener title="discord link" class="sc-site-header" c-id=4.73.2.2><svg class="social sc-site-header"
width=20 height=16 fill=none xmlns="http://www.w3.org/2000/svg" c-id=4.74.3.0><path d="M16.93 1.33A15.93 15.93 0 0 0 12.86 0c-.03 0-.05 0-.07.03-.17.33-.37.76-.5 1.1a14.52 14.52 0 0 0-4.57 0A11.3 11.3 0 0 0 7.2.03.06.06 0 0 0 7.14 0a15.89 15.89 0 0 0-4.1 1.35 18.4 18.4 0 0 0-2.93 12 16.3 16.3 0 0 0 5 2.65c.02 0 .05 0 .06-.03.39-.55.73-1.13 1.02-1.74a.07.07 0 0 0-.03-.1 10.7 10.7 0 0 1-1.56-.77.07.07 0 0 1 0-.12l.3-.25a.06.06 0 0 1 .07-.01 11.32 11.32 0 0 0 10.05 0h.06c.1.1.21.18.32.26.03.03.03.1-.01.12-.5.3-1.02.56-1.56.78a.07.07 0 0 0-.04.09c.3.6.65 1.2 1.03 1.74.01.03.04.04.07.03a16.24 16.24 0 0 0 5.02-2.7 18.26 18.26 0 0 0-2.98-11.97ZM6.68 10.9c-.98 0-1.8-.95-1.8-2.11 0-1.17.8-2.12 1.8-2.12 1.01 0 1.82.96 1.8 2.12 0 1.16-.8 2.11-1.8 2.11Zm6.65 0c-.99 0-1.8-.95-1.8-2.11 0-1.17.8-2.12 1.8-2.12s1.81.96 1.8 2.12c0 1.16-.8 2.11-1.8 2.11Z"
fill=#B2BECD class="sc-site-header" c-id=4.75.4.0></path></svg></a><a href="https://twitter.com/capacitorjs"
target=_blank rel=noopener class="sc-site-header" c-id=4.76.2.3><svg class="social sc-site-header" width=18
height=16 fill=none xmlns="http://www.w3.org/2000/svg" c-id=4.77.3.0><path d="M18 1.9c-.66.32-1.37.53-2.12.63A4 4 0 0 0 17.5.3c-.7.46-1.5.8-2.34.98A3.55 3.55 0 0 0 12.46 0c-2.04 0-3.7 1.8-3.7 4.04 0 .31.04.62.1.92A10.2 10.2 0 0 1 1.26.74 4.33 4.33 0 0 0 2.4 6.13a3.38 3.38 0 0 1-1.68-.5v.04a3.97 3.97 0 0 0 2.96 3.96 3.42 3.42 0 0 1-1.66.07 3.76 3.76 0 0 0 3.45 2.8A7.02 7.02 0 0 1 0 14.18 9.7 9.7 0 0 0 5.65 16c6.8 0 10.52-6.15 10.52-11.5L16.16 4A7.94 7.94 0 0 0 18 1.89Z"
fill=#B2BECD class="sc-site-header" c-id=4.78.4.0></path></svg></a><a tabindex=0 class="ui-button ui-button-md ui-button-regular ui-button-cyan ui-button-fill primary | ui-paragraph-4 sc-site-header"
href="/docs/getting-started" c-id=4.79.2.4><svg width=10 height=12 xmlns="http://www.w3.org/2000/svg"
viewBox="0 0 400 520.31" class="sc-site-header" c-id=4.80.3.0><path fill=#fff d="M179.5 167.9l-.2 167.9-57.76-55.44-57.76-55.43-1.72 1.8L48.1 241.3c-6.73 7.03-12.13 13.03-12 13.34.41 1 163.29 157.08 163.92 157.08.62 0 163.46-156.09 163.88-157.09.13-.3-5.27-6.3-12-13.33l-13.96-14.58-1.72-1.8-57.76 55.44-57.76 55.44-.2-167.9L220.3 0h-40.6l-.2 167.9M0 479.69V500h400v-40.62H0v20.3"
fill-rule=evenodd class="sc-site-header" c-id=4.81.4.0></path></svg><!--t.4.82.3.1-->Install</a></div></header></site-header><landing-page
class="sc-landing-page-h sc-landing-page-s hydrated" c-id=1.4.2.2 s-id=15><!--r.15--><meta-tags class="sc-landing-page hydrated"
c-id=15.0.0.0 s-id=16><!--r.16--></meta-tags><section id=top class="sc-landing-page" c-id=15.1.0.1><div
class="background sc-landing-page" c-id=15.2.1.0></div><div class="ui-container sc-landing-page" c-id=15.3.1.1><div
class="heading-group sc-landing-page" c-id=15.4.2.0><a id=announcement class="feature__register sc-landing-page"
href="https://ionicframework.com/blog/announcing-capacitor-3-0/" target=_blank rel=noopener c-id=15.5.3.0><div
class="tag sc-landing-page" c-id=15.6.4.0><!--t.15.7.5.0-->Blog</div><div class="ui-breakpoint ui-breakpoint-sm ui-breakpoint-md ui-breakpoint-lg ui-breakpoint-xl text sc-landing-page"
c-id=15.8.4.1 style="--display: inline-block;"><span class="text__content sc-landing-page" c-id=15.9.5.0><!--t.15.10.6.0-->Announcing Capacitor 3.0
<span class="arrow sc-landing-page" c-id=15.11.6.1><!--t.15.12.7.0-->-&gt;</span></span></div><div
class="ui-breakpoint ui-breakpoint-xs text sc-landing-page" c-id=15.13.4.2
style="--display: inline-block;"><span class="text__content sc-landing-page" c-id=15.14.5.0><!--t.15.15.6.0-->Capacitor 3.0 <span
class="arrow sc-landing-page" c-id=15.16.6.1><!--t.15.17.7.0-->-&gt;</span></span></div></a><h1 id="h-a-cross-platform-native-runtime-for-web-apps"
class="ui-heading ui-heading-1 sc-landing-page" c-id=15.18.3.1><!--t.15.19.4.0-->A cross-platform native runtime for web apps.</h1><p
class="ui-paragraph ui-paragraph-2 ui-paragraph--body sc-landing-page" c-id=15.20.3.2><!--t.15.21.4.0-->Capacitor is an open source native runtime for building Web Native apps. Create cross-platform iOS, Android, and Progressive Web Apps with JavaScript, HTML, and CSS.</p><div
class="buttons sc-landing-page" c-id=15.22.3.3><a tabindex=0 href="/docs/getting-started" class="ui-button ui-button-lg ui-button-round ui-button-blue ui-button-fill primary sc-landing-page"
c-id=15.23.4.0><!--t.15.24.5.0-->Install Capacitor <span class="arrow sc-landing-page" c-id=15.25.5.1><!--t.15.26.6.0--> -&gt;</span></a><a
tabindex=0 href="/docs/plugins" class="ui-button ui-button-lg ui-button-round ui-button-blue ui-button-light secondary sc-landing-page"
c-id=15.27.4.1><!--t.15.28.5.0-->Explore Plugins</a></div><a class="link | ui-paragraph-4 sc-landing-page"
href="/cordova" c-id=15.29.3.4><!--t.15.30.4.0-->Migrate from Cordova<span class="arrow sc-landing-page"
c-id=15.31.4.1><!--t.15.32.5.0--> -&gt;</span></a><img loading=eager src="https://images.prismic.io/ionicframeworkcom/2572b6ec-4952-4ba7-959a-d8aabe80a5c2_capacitor-homepage-top-1%402x.png?auto=compress,format&amp;rect=0,0,183,32&amp;w=92&amp;h=16&amp;q=65"
srcset="https://images.prismic.io/ionicframeworkcom/2572b6ec-4952-4ba7-959a-d8aabe80a5c2_capacitor-homepage-top-1%402x.png?auto=compress,format&amp;rect=0,0,183,32&amp;w=92&amp;h=16&amp;q=65 1x, https://images.prismic.io/ionicframeworkcom/2572b6ec-4952-4ba7-959a-d8aabe80a5c2_capacitor-homepage-top-1%402x.png?auto=compress,format&amp;rect=0,0,183,33&amp;w=183&amp;h=33&amp;q=65 2x"
width=92 height=16 alt="apple, android and pwa icons" class="sc-landing-page" c-id=15.33.3.5></div><div
class="image-wrapper sc-landing-page" c-id=15.34.2.1><img loading=eager src="https://images.prismic.io/ionicframeworkcom/ffa25bb6-a032-44e4-b2f6-b83c5a73226f_capacitor-homepage-top-0%402x.png?auto=compress,format&amp;rect=0,0,1089,1219&amp;w=545&amp;h=610&amp;q=65"
srcset="https://images.prismic.io/ionicframeworkcom/ffa25bb6-a032-44e4-b2f6-b83c5a73226f_capacitor-homepage-top-0%402x.png?auto=compress,format&amp;rect=0,0,1089,1219&amp;w=545&amp;h=610&amp;q=65 1x, https://images.prismic.io/ionicframeworkcom/ffa25bb6-a032-44e4-b2f6-b83c5a73226f_capacitor-homepage-top-0%402x.png?auto=compress,format&amp;rect=0,0,1089,1220&amp;w=1089&amp;h=1220&amp;q=65 2x"
width=545 height=610 alt="layered stack of phone app showing capacitor in the middle" class="sc-landing-page"
c-id=15.35.3.0></div></div></section><section id=started class="ui-container sc-landing-page" c-id=15.36.0.2><div
class="heading-group sc-landing-page" c-id=15.37.1.0><h2 id="h-get-started-easily" class="ui-heading ui-heading-2 sc-landing-page"
c-id=15.38.2.0><!--t.15.39.3.0-->Get started <em class="sc-landing-page" c-id=15.40.3.1><!--t.15.41.4.0-->easily.</em></h2></div><div
class="step sc-landing-page" c-id=15.42.1.1><sup class="ui-heading-6 sc-landing-page" c-id=15.43.2.0><!--t.15.44.3.0-->01</sup><div
class="heading-panel-wrapper sc-landing-page" c-id=15.45.2.1><div class="heading-wrapper sc-landing-page"
c-id=15.46.3.0><h3 class="ui-heading ui-heading-3 sc-landing-page" c-id=15.47.4.0><!--t.15.48.5.0-->Drop Capacitor into any existing web app.</h3></div><div
class="panel sc-landing-page" c-id=15.49.3.1><code-snippet class="sc-landing-page sc-code-snippet-h hydrated"
c-id=15.50.4.0 s-id=17><!--r.17--><pre class="language-shell-session sc-code-snippet" c-id=17.0.0.0><code
class="sc-code-snippet" c-id=17.1.1.0><!--t.17.2.2.0-->npm install @capacitor/cli @capacitor/core
npx cap init</code></pre></code-snippet></div></div></div><div
class="step sc-landing-page" c-id=15.51.1.2><sup class="ui-heading-6 sc-landing-page" c-id=15.52.2.0><!--t.15.53.3.0-->02</sup><div
class="heading-panel-wrapper sc-landing-page" c-id=15.54.2.1><div class="heading-wrapper sc-landing-page"
c-id=15.55.3.0><h3 class="ui-heading ui-heading-3 sc-landing-page" c-id=15.56.4.0><!--t.15.57.5.0-->Install the native platforms you want to target.</h3><div
class="platforms sc-landing-page" c-id=15.58.4.1><img width=22 height=26 loading=lazy src="https://images.prismic.io/ionicframeworkcom/c6924d12-09fa-46ac-b2fc-48142426428d_capacitor-homepage-started-0%402x.png?auto=compress,format&amp;q=65"
alt="apple icon" class="sc-landing-page" c-id=15.59.5.0><img width=27 height=23 loading=lazy src="https://images.prismic.io/ionicframeworkcom/216793f2-1c11-490e-8463-622f87d593b6_capacitor-homepage-started-1%402x.png?auto=compress,format&amp;q=65"
alt="android icon" class="sc-landing-page" c-id=15.60.5.1></div></div><div class="panel sc-landing-page"
c-id=15.61.3.1><code-snippet class="sc-landing-page sc-code-snippet-h hydrated" c-id=15.62.4.0 s-id=18><!--r.18--><pre
class="language-shell-session sc-code-snippet" c-id=18.0.0.0><code class="sc-code-snippet" c-id=18.1.1.0><!--t.18.2.2.0-->npm install @capacitor/ios @capacitor/android
npx cap add ios
npx cap add android</code></pre></code-snippet></div></div></div><div
class="step sc-landing-page" c-id=15.63.1.3><sup class="ui-heading-6 sc-landing-page" c-id=15.64.2.0><!--t.15.65.3.0-->03</sup><div
class="heading-panel-wrapper sc-landing-page" c-id=15.66.2.1><div class="heading-wrapper sc-landing-page"
c-id=15.67.3.0><h3 class="ui-heading ui-heading-3 sc-landing-page" c-id=15.68.4.0><!--t.15.69.5.0-->Access core Native APIs or extend with your own.</h3><p
class="ui-paragraph ui-paragraph-3 ui-paragraph--body sc-landing-page" c-id=15.70.4.1><!--t.15.71.5.0-->Capacitor’s native plugin APIs make it extremely easy to access and invoke common device functionality across multiple platforms.</p></div><div
class="panel sc-landing-page" c-id=15.72.3.1><code-tabs class="sc-landing-page sc-code-tabs-h sc-code-tabs-s hydrated"
c-id=15.73.4.0 s-id=19 style="--tab-left: 0px; --tab-width: 0px;"><!--r.19--><nav class="sc-code-tabs"
c-id=19.0.0.0><div class="tabs-wrapper sc-code-tabs" c-id=19.1.1.0><button class="active sc-code-tabs"
c-id=19.2.2.0><!--t.19.3.3.0-->Notifications</button><button class="sc-code-tabs" c-id=19.4.2.1><!--t.19.5.3.0-->Geolocation</button><button
class="sc-code-tabs" c-id=19.6.2.2><!--t.19.7.3.0-->Camera</button><button class="sc-code-tabs" c-id=19.8.2.3><!--t.19.9.3.0-->Custom</button></div></nav><div
class="background sc-code-tabs" c-id=19.10.0.1><div class="code-wrapper sc-code-tabs" c-id=19.11.1.0><article
class="sc-code-tabs" c-id=19.12.2.0><code-snippet class="sc-code-tabs sc-code-snippet-h hydrated" c-id=19.13.3.0
s-id=20><!--r.20--><pre class="language-typescript sc-code-snippet" c-id=20.0.0.0><code class="sc-code-snippet"
c-id=20.1.1.0><!--t.20.2.2.0-->import { LocalNotifications } from '@capacitor/local-notifications';

LocalNotifications.schedule({
  notifications: [
    {
      title: "On sale",
      body: "Widgets are 10% off. Act fast!",
      id: 1,
      schedule: { at: new Date(Date.now() + 1000 * 5) },
      sound: null,
      attachments: null,
      actionTypeId: "",
      extra: null
    }
  ]
});</code></pre></code-snippet></article><article
class="sc-code-tabs" c-id=19.14.2.1><code-snippet class="sc-code-tabs sc-code-snippet-h hydrated" c-id=19.15.3.0
s-id=21><!--r.21--><pre class="language-typescript sc-code-snippet" c-id=21.0.0.0><code class="sc-code-snippet"
c-id=21.1.1.0><!--t.21.2.2.0-->import { Geolocation } from '@capacitor/geolocation';

// get the users current position
const position = await Geolocation.getCurrentPosition();

// grab latitude &amp; longitude
const latitude = position.coords.latitude;
const longitude = position.coords.longitude;</code></pre></code-snippet></article><article
class="sc-code-tabs" c-id=19.16.2.2><code-snippet class="sc-code-tabs sc-code-snippet-h hydrated" c-id=19.17.3.0
s-id=22><!--r.22--><pre class="language-typescript sc-code-snippet" c-id=22.0.0.0><code class="sc-code-snippet"
c-id=22.1.1.0><!--t.22.2.2.0-->import { Camera, CameraResultType } from '@capacitor/camera';

// Take a picture or video, or load from the library
const picture = await Camera.getPicture({
  resultType: CameraResultType.Uri
});</code></pre></code-snippet></article><article
class="sc-code-tabs" c-id=19.18.2.3><code-snippet class="sc-code-tabs sc-code-snippet-h hydrated" c-id=19.19.3.0
s-id=23><!--r.23--><pre class="language-typescript sc-code-snippet" c-id=23.0.0.0><code class="sc-code-snippet"
c-id=23.1.1.0><!--t.23.2.2.0-->import Foundation
import Capacitor

// Custom platform code, easily exposed to your web app
// through Capacitor plugin APIs. Build APIs that work
// across iOS, Android, and the web!
@objc(MyAwesomePlugin)
public class MyAwesomePlugin: CAPPlugin {

  @objc public func doNative(_ call: CAPPluginCall) {
  let alert = UIAlertController(title: "Title", message: "Please Select an Option", preferredStyle: .actionSheet)

  // ....
  }
}</code></pre></code-snippet></article></div></div></code-tabs></div></div></div></section><section
id=ebook class="sc-landing-page" c-id=15.74.0.3><div class="ui-container sc-landing-page" c-id=15.75.1.0><site-modal
class="sc-landing-page hydrated" c-id=15.76.2.0 s-id=24 style="display: none;"><!--r.24--><!--o.15.77--><!--o.15.79--><div
class=modal__wrap c-id=24.0.0.0><div class=modal__content c-id=24.1.1.0><button class="ui-button ui-button-lg ui-button-display ui-button-blue ui-button-fill modal__close-button"
c-id=24.2.2.0><ion-icon class="sc-ion-icon-h md hydrated" role=img aria-label=close c-id=24.3.3.0 s-id=25><!--r.25--><div
class="icon-inner sc-ion-icon" c-id=25.0.0.0></div></ion-icon></button><div class=modal__body c-id=24.4.2.1><!--s.24.5.3.0.--><h2
class="ui-heading ui-heading-2 sc-landing-page" c-id=15.77.3.0><!--t.15.78.4.0-->Building Cross-platform Apps with Capacitor</h2><hubspot-form
class="sc-landing-page hydrated" c-id=15.79.3.1 s-id=26><!--r.26--><div class="hubspot-override" c-id=26.0.0.0><div
id="hbspt-form-9151dc0b-42d9-479f-b7b8-649e0e7bd1bc" c-id=26.1.1.0></div></div></hubspot-form></div></div></div></site-modal><div
class="wrapper sc-landing-page" c-id=15.80.2.1><img class="background sc-landing-page" loading=lazy src="https://images.prismic.io/ionicframeworkcom/c07acb65-dd7c-48b5-9aad-b3a1f603a6f9_capacitor-enterprise-ebook-0%402x.png?auto=compress,format&amp;rect=0,0,2432,640&amp;w=1216&amp;h=320&amp;q=65"
srcset="https://images.prismic.io/ionicframeworkcom/c07acb65-dd7c-48b5-9aad-b3a1f603a6f9_capacitor-enterprise-ebook-0%402x.png?auto=compress,format&amp;rect=0,0,2432,640&amp;w=1216&amp;h=320&amp;q=65 1x, https://images.prismic.io/ionicframeworkcom/c07acb65-dd7c-48b5-9aad-b3a1f603a6f9_capacitor-enterprise-ebook-0%402x.png?auto=compress,format&amp;rect=0,0,2432,640&amp;w=2432&amp;h=640&amp;q=65 2x"
width=1216 height=320 alt="see through tiles" c-id=15.81.3.0><div class="content sc-landing-page" c-id=15.82.3.1><div
class="image-wrapper sc-landing-page" c-id=15.83.4.0><img loading=lazy src="https://images.prismic.io/ionicframeworkcom/3814b138-c048-42e6-bf55-4577ad0a7674_capacitor-enterprise-ebook-1%402x.png?auto=compress,format&amp;rect=0,0,728,686&amp;w=364&amp;h=343&amp;q=65"
srcset="https://images.prismic.io/ionicframeworkcom/3814b138-c048-42e6-bf55-4577ad0a7674_capacitor-enterprise-ebook-1%402x.png?auto=compress,format&amp;rect=0,0,728,686&amp;w=364&amp;h=343&amp;q=65 1x, https://images.prismic.io/ionicframeworkcom/3814b138-c048-42e6-bf55-4577ad0a7674_capacitor-enterprise-ebook-1%402x.png?auto=compress,format&amp;rect=0,0,728,686&amp;w=728&amp;h=686&amp;q=65 2x"
width=364 height=343 alt="book cover with title reading &quot;Building Cross-platform Apps with Capacitor&quot;"
class="sc-landing-page" c-id=15.84.5.0></div><div class="heading-group sc-landing-page" c-id=15.85.4.1><p
class="ui-paragraph ui-paragraph-1 ui-paragraph--body sc-landing-page" c-id=15.86.5.0><em class="sc-landing-page"
c-id=15.87.6.0><!--t.15.88.7.0-->Ship cross-platform mobile apps 10X faster.</em><!--t.15.89.6.1--> We wrote a free guide on when and why to use Capacitor to build cross-platform apps.</p><button
class="ui-button ui-button-md ui-button-round ui-button-blue ui-button-fill sc-landing-page" c-id=15.90.5.1><!--t.15.91.6.0-->Read the free eBook
<span class="arrow sc-landing-page" c-id=15.92.6.1><!--t.15.93.7.0--> -&gt;</span></button></div></div></div></div></section><section
id=native class="ui-container sc-landing-page" c-id=15.94.0.4><div class="heading-group sc-landing-page"
c-id=15.95.1.0><h2 id="h-connect-web-apps-to-native-functionality" class="ui-heading ui-heading-2 sc-landing-page"
c-id=15.96.2.0><!--t.15.97.3.0-->Connect web apps to <em class="sc-landing-page" c-id=15.98.3.1><!--t.15.99.4.0-->native functionality.</em></h2></div><div
class="ui-grid sc-landing-page" c-id=15.100.1.1><div class="ui-col ui-col-12 ui-col-xs-6 ui-col-sm-4 sc-landing-page"
c-id=15.101.2.0><img width=48 height=64 loading=lazy src="https://images.prismic.io/ionicframeworkcom/4b5c4f07-ffa0-44de-9c7e-213cc7c9e22a_capacitor-homepage-native-0%402x.png?auto=compress,format&amp;q=65"
alt="triple phone icon" class="sc-landing-page" c-id=15.102.3.0><h4 id="h-universal-apps" class="ui-heading ui-heading-4 sc-landing-page"
c-id=15.103.3.1><!--t.15.104.4.0-->Universal apps</h4><p class="ui-paragraph ui-paragraph-3 ui-paragraph--body sc-landing-page"
c-id=15.105.3.2><!--t.15.106.4.0-->Build web-based applications that run equally well across iOS, Android, and as Progressive Web Apps.</p></div><div
class="ui-col ui-col-12 ui-col-xs-6 ui-col-sm-4 sc-landing-page" c-id=15.107.2.1><img width=60 height=64
loading=lazy src="https://images.prismic.io/ionicframeworkcom/98f4ff08-7ae1-4284-b0d9-1ad7a765e29e_capacitor-homepage-native-1%402x.png?auto=compress,format&amp;q=65"
alt="Cube with sphere inside icon" class="sc-landing-page" c-id=15.108.3.0><h4 id="h-native-access"
class="ui-heading ui-heading-4 sc-landing-page" c-id=15.109.3.1><!--t.15.110.4.0-->Native access</h4><p
class="ui-paragraph ui-paragraph-3 ui-paragraph--body sc-landing-page" c-id=15.111.3.2><!--t.15.112.4.0-->Access the full Native SDKs on each platform, and easily deploy to the App Stores (and the web).</p></div><div
class="ui-col ui-col-12 ui-col-xs-6 ui-col-sm-4 sc-landing-page" c-id=15.113.2.2><img width=60 height=64
loading=lazy src="https://images.prismic.io/ionicframeworkcom/bd588d01-ec62-43c8-8bb9-68ddc3eeb792_capacitor-homepage-native-2%402x.png?auto=compress,format&amp;q=65"
alt="Tripe phone stack layered icon" class="sc-landing-page" c-id=15.114.3.0><h4 id="h-native-pwas"
class="ui-heading ui-heading-4 sc-landing-page" c-id=15.115.3.1><!--t.15.116.4.0-->Native PWAs</h4><p
class="ui-paragraph ui-paragraph-3 ui-paragraph--body sc-landing-page" c-id=15.117.3.2><!--t.15.118.4.0-->Add custom native functionality with a simple Plugin API, or use existing Cordova plugins with our compatibility layer.</p></div></div></section><section
id=features class="sc-landing-page" c-id=15.119.0.5><div class="ui-container sc-landing-page" c-id=15.120.1.0><div
class="heading-group sc-landing-page" c-id=15.121.2.0><h2 id="h-cross-platform-core-native-plugins" class="ui-heading ui-heading-2 sc-landing-page"
c-id=15.122.3.0><!--t.15.123.4.0-->Cross-platform, <em class="sc-landing-page" c-id=15.124.4.1><!--t.15.125.5.0-->core native plugins.</em></h2><a
href="/docs/apis" class="link | ui-heading-4 sc-landing-page" c-id=15.126.3.1><!--t.15.127.4.0-->Explore APIs<span
class="arrow sc-landing-page" c-id=15.128.4.1><!--t.15.129.5.0-->-&gt;</span></a></div><div class="ui-grid sc-landing-page"
c-id=15.130.2.1><div class="ui-col ui-col-12 ui-col-xs-6 ui-col-sm-4 ui-col-md-3 sc-landing-page" c-id=15.131.3.0><img
width=40 height=32 loading=lazy src="https://images.prismic.io/ionicframeworkcom/10d8370b-8862-4e01-9de4-cdc968ba6290_capacitor-homepage-features-0%402x.png?auto=compress,format&amp;q=65"
alt="camera icon" class="sc-landing-page" c-id=15.132.4.0><h4 id="h-camera" class="ui-heading ui-heading-4 sc-landing-page"
c-id=15.133.4.1><!--t.15.134.5.0-->Camera</h4><p class="ui-paragraph ui-paragraph-3 ui-paragraph--body sc-landing-page"
c-id=15.135.4.2><!--t.15.136.5.0-->Capture images, save photos, and configure hardware parameters like saturation and color balance.</p><p
class="ui-paragraph ui-paragraph-3 ui-paragraph--body sc-landing-page" c-id=15.137.4.3></p></div><div
class="ui-col ui-col-12 ui-col-xs-6 ui-col-sm-4 ui-col-md-3 sc-landing-page" c-id=15.138.3.1><img width=40
height=32 loading=lazy src="https://images.prismic.io/ionicframeworkcom/98367b04-f749-4462-b0fc-c8492c55f6d7_capacitor-homepage-features-1%402x.png?auto=compress,format&amp;q=65"
alt="file system icon" class="sc-landing-page" c-id=15.139.4.0><h4 id="h-file-system" class="ui-heading ui-heading-4 sc-landing-page"
c-id=15.140.4.1><!--t.15.141.5.0-->File System</h4><p class="ui-paragraph ui-paragraph-3 ui-paragraph--body sc-landing-page"
c-id=15.142.4.2><!--t.15.143.5.0-->Save and read documents, assets, and other content your users need to access via native file systems.</p></div><div
class="ui-col ui-col-12 ui-col-xs-6 ui-col-sm-4 ui-col-md-3 sc-landing-page" c-id=15.144.3.2><img width=32
height=32 loading=lazy src="https://images.prismic.io/ionicframeworkcom/7cfc3a6a-b3ba-4be2-9b9e-c930a9ee8a87_capacitor-homepage-features-2%402x.png?auto=compress,format&amp;q=65"
alt="antenna icon" class="sc-landing-page" c-id=15.145.4.0><h4 id="h-geolocation" class="ui-heading ui-heading-4 sc-landing-page"
c-id=15.146.4.1><!--t.15.147.5.0-->Geolocation</h4><p class="ui-paragraph ui-paragraph-3 ui-paragraph--body sc-landing-page"
c-id=15.148.4.2><!--t.15.149.5.0-->Gather critical information about a user’s device  location, such as latitude and longitude.</p></div><div
class="ui-col ui-col-12 ui-col-xs-6 ui-col-sm-4 ui-col-md-3 sc-landing-page" c-id=15.150.3.3><img width=33
height=32 loading=lazy src="https://images.prismic.io/ionicframeworkcom/5228d616-ee0d-45f0-b770-ef7fddf6b6d2_capacitor-homepage-features-3%402x.png?auto=compress,format&amp;q=65"
alt="spherical rings icon" class="sc-landing-page" c-id=15.151.4.0><h4 id="h-accelerometer" class="ui-heading ui-heading-4 sc-landing-page"
c-id=15.152.4.1><!--t.15.153.5.0-->Accelerometer</h4><p class="ui-paragraph ui-paragraph-3 ui-paragraph--body sc-landing-page"
c-id=15.154.4.2><!--t.15.155.5.0-->Access the device accelerometer sensors to measures changes in velocity of a device motion.</p></div><div
class="ui-col ui-col-12 ui-col-xs-6 ui-col-sm-4 ui-col-md-3 sc-landing-page" c-id=15.156.3.4><img width=28
height=32 loading=lazy src="https://images.prismic.io/ionicframeworkcom/bdedc90e-ca59-4a30-84a7-937b1a43dce5_capacitor-homepage-features-4%402x.png?auto=compress,format&amp;q=65"
alt="bell icon" class="sc-landing-page" c-id=15.157.4.0><h4 id="h-notifications" class="ui-heading ui-heading-4 sc-landing-page"
c-id=15.158.4.1><!--t.15.159.5.0-->Notifications</h4><p class="ui-paragraph ui-paragraph-3 ui-paragraph--body sc-landing-page"
c-id=15.160.4.2><!--t.15.161.5.0-->Schedule local notifications on the device or handle push notifications sent from a server.</p></div><div
class="ui-col ui-col-12 ui-col-xs-6 ui-col-sm-4 ui-col-md-3 sc-landing-page" c-id=15.162.3.5><img width=32
height=32 loading=lazy src="https://images.prismic.io/ionicframeworkcom/59dded8c-15e0-497b-9c16-2445dff24034_capacitor-homepage-features-5%402x.png?auto=compress,format&amp;q=65"
alt="person with circle around icon" class="sc-landing-page" c-id=15.163.4.0><h4 id="h-network" class="ui-heading ui-heading-4 sc-landing-page"
c-id=15.164.4.1><!--t.15.165.5.0-->Network</h4><p class="ui-paragraph ui-paragraph-3 ui-paragraph--body sc-landing-page"
c-id=15.166.4.2><!--t.15.167.5.0-->Monitor for network connectivity and capability changes to build resilient offline apps.</p></div><div
class="ui-col ui-col-12 ui-col-xs-6 ui-col-sm-4 ui-col-md-3 sc-landing-page" c-id=15.168.3.6><img width=32
height=32 loading=lazy src="https://images.prismic.io/ionicframeworkcom/31ac9e1d-0993-4ad6-a35d-27356bdf4820_capacitor-homepage-features-6%402x.png?auto=compress,format&amp;q=65"
alt="three encompassing circles icon" class="sc-landing-page" c-id=15.169.4.0><h4 id="h-haptics" class="ui-heading ui-heading-4 sc-landing-page"
c-id=15.170.4.1><!--t.15.171.5.0-->Haptics</h4><p class="ui-paragraph ui-paragraph-3 ui-paragraph--body sc-landing-page"
c-id=15.172.4.2><!--t.15.173.5.0-->Add physical feedback through haptic features available on modern devices.</p></div><div
class="ui-col ui-col-12 ui-col-xs-6 ui-col-sm-4 ui-col-md-3 sc-landing-page" c-id=15.174.3.7><img width=32
height=30 loading=lazy src="https://images.prismic.io/ionicframeworkcom/523aa1bb-a036-423d-812b-3eccdc0ee3c9_capacitor-homepage-features-7%402x.png?auto=compress,format&amp;q=65"
alt="slider adjustment icon" class="sc-landing-page" c-id=15.175.4.0><h4 id="h-your-own-plugin" class="ui-heading ui-heading-4 sc-landing-page"
c-id=15.176.4.1><!--t.15.177.5.0-->Your Own Plugin</h4><p class="ui-paragraph ui-paragraph-3 ui-paragraph--body sc-landing-page"
c-id=15.178.4.2><!--t.15.179.5.0-->Write your own custom plugins to access specialty features and easily integrate any 3rd-party SDK.</p></div></div></div></section><section
id=framework class="ui-container sc-landing-page" c-id=15.180.0.6><div class="heading-group sc-landing-page"
c-id=15.181.1.0><h2 id="h-bring-your-own-web-framework" class="ui-heading ui-heading-2 sc-landing-page"
c-id=15.182.2.0><!--t.15.183.3.0-->Bring your own <em class="sc-landing-page" c-id=15.184.3.1><!--t.15.185.4.0-->web framework.</em></h2><p
class="ui-paragraph ui-paragraph-2 ui-paragraph--body sc-landing-page" c-id=15.186.2.1><!--t.15.187.3.0-->Drop Capacitor into any existing web project, framework or library. Convert an existing
<a href="https://capacitorjs.com/solution/react"
class="sc-landing-page" c-id=15.188.3.1><!--t.15.189.4.0-->React</a><!--t.15.190.3.2-->, <a href="https://capacitorjs.com/solution/svelte"
class="sc-landing-page" c-id=15.191.3.3><!--t.15.192.4.0-->Svelte</a><!--t.15.193.3.4-->, <a href="https://capacitorjs.com/solution/vue"
class="sc-landing-page" c-id=15.194.3.5><!--t.15.195.4.0-->Vue</a><!--t.15.196.3.6--> (or your preferred Web Framework) project to native mobile.</p></div><div
class="ui-grid sc-landing-page" c-id=15.197.1.1><div class="ui-col ui-col-6 ui-col-sm-3 sc-landing-page"
c-id=15.198.2.0><a href="/solution/react" class="sc-landing-page" c-id=15.199.3.0><img width=272 height=200
loading=lazy src="https://images.prismic.io/ionicframeworkcom/a8d6639f-4ded-4f8a-b651-8f75c57b0a95_capacitor-homepage-framework-0%402x.png?auto=compress,format&amp;rect=0,0,544,400&amp;w=272&amp;h=200&amp;q=65"
srcset="https://images.prismic.io/ionicframeworkcom/a8d6639f-4ded-4f8a-b651-8f75c57b0a95_capacitor-homepage-framework-0%402x.png?auto=compress,format&amp;rect=0,0,544,400&amp;w=272&amp;h=200&amp;q=65 1x, https://images.prismic.io/ionicframeworkcom/a8d6639f-4ded-4f8a-b651-8f75c57b0a95_capacitor-homepage-framework-0%402x.png?auto=compress,format&amp;rect=0,0,544,400&amp;w=544&amp;h=400&amp;q=65 2x"
alt="react logo tile" class="sc-landing-page" c-id=15.200.4.0></a></div><div class="ui-col ui-col-6 ui-col-sm-3 sc-landing-page"
c-id=15.201.2.1><a href="/solution/angular" class="sc-landing-page" c-id=15.202.3.0><img width=272
height=200 loading=lazy src="https://images.prismic.io/ionicframeworkcom/eabaddbd-4e18-444d-9dda-94b5c44d8680_capacitor-homepage-framework-1%402x.png?auto=compress,format&amp;rect=0,0,544,400&amp;w=272&amp;h=200&amp;q=65"
srcset="https://images.prismic.io/ionicframeworkcom/eabaddbd-4e18-444d-9dda-94b5c44d8680_capacitor-homepage-framework-1%402x.png?auto=compress,format&amp;rect=0,0,544,400&amp;w=272&amp;h=200&amp;q=65 1x, https://images.prismic.io/ionicframeworkcom/eabaddbd-4e18-444d-9dda-94b5c44d8680_capacitor-homepage-framework-1%402x.png?auto=compress,format&amp;rect=0,0,544,400&amp;w=544&amp;h=400&amp;q=65 2x"
alt="angular logo tile" class="sc-landing-page" c-id=15.203.4.0></a></div><div class="ui-col ui-col-6 ui-col-sm-3 sc-landing-page"
c-id=15.204.2.2><a href="/solution/svelte" class="sc-landing-page" c-id=15.205.3.0><img width=272 height=200
loading=lazy src="https://images.prismic.io/ionicframeworkcom/a3e688e2-ca5f-4b52-ae2c-6ddb242ed85f_capacitor-homepage-framework-2%402x.png?auto=compress,format&amp;rect=0,0,544,400&amp;w=272&amp;h=200&amp;q=65"
srcset="https://images.prismic.io/ionicframeworkcom/a3e688e2-ca5f-4b52-ae2c-6ddb242ed85f_capacitor-homepage-framework-2%402x.png?auto=compress,format&amp;rect=0,0,544,400&amp;w=272&amp;h=200&amp;q=65 1x, https://images.prismic.io/ionicframeworkcom/a3e688e2-ca5f-4b52-ae2c-6ddb242ed85f_capacitor-homepage-framework-2%402x.png?auto=compress,format&amp;rect=0,0,544,400&amp;w=544&amp;h=400&amp;q=65 2x"
alt="svelte logo tile" class="sc-landing-page" c-id=15.206.4.0></a></div><div class="ui-col ui-col-6 ui-col-sm-3 sc-landing-page"
c-id=15.207.2.3><a href="/solution/vue" class="sc-landing-page" c-id=15.208.3.0><img width=272 height=200
loading=lazy src="https://images.prismic.io/ionicframeworkcom/ac5b82ec-5c50-43d8-89c3-5106738c5ad0_capacitor-homepage-framework-3%402x.png?auto=compress,format&amp;rect=0,0,544,400&amp;w=272&amp;h=200&amp;q=65"
srcset="https://images.prismic.io/ionicframeworkcom/ac5b82ec-5c50-43d8-89c3-5106738c5ad0_capacitor-homepage-framework-3%402x.png?auto=compress,format&amp;rect=0,0,544,400&amp;w=272&amp;h=200&amp;q=65 1x, https://images.prismic.io/ionicframeworkcom/ac5b82ec-5c50-43d8-89c3-5106738c5ad0_capacitor-homepage-framework-3%402x.png?auto=compress,format&amp;rect=0,0,544,400&amp;w=544&amp;h=400&amp;q=65 2x"
alt="vue logo tile" class="sc-landing-page" c-id=15.209.4.0></a></div><div class="ui-col ui-col-6 ui-col-sm-3 sc-landing-page"
c-id=15.210.2.4><a href="/solution/stencil" class="sc-landing-page" c-id=15.211.3.0><img width=272
height=200 loading=lazy src="https://images.prismic.io/ionicframeworkcom/43881f8e-3cf3-45fa-bbb3-0bbaf8fb3901_capacitor-homepage-framework-4%402x.png?auto=compress,format&amp;rect=0,0,544,400&amp;w=272&amp;h=200&amp;q=65"
srcset="https://images.prismic.io/ionicframeworkcom/43881f8e-3cf3-45fa-bbb3-0bbaf8fb3901_capacitor-homepage-framework-4%402x.png?auto=compress,format&amp;rect=0,0,544,400&amp;w=272&amp;h=200&amp;q=65 1x, https://images.prismic.io/ionicframeworkcom/43881f8e-3cf3-45fa-bbb3-0bbaf8fb3901_capacitor-homepage-framework-4%402x.png?auto=compress,format&amp;rect=0,0,544,400&amp;w=544&amp;h=400&amp;q=65 2x"
alt="stencil logo tile" class="sc-landing-page" c-id=15.212.4.0></a></div><div class="ui-col ui-col-6 ui-col-sm-3 sc-landing-page"
c-id=15.213.2.5><img width=272 height=200 loading=lazy src="https://images.prismic.io/ionicframeworkcom/25d29076-9c99-445c-b367-b5a0caba93ae_capacitor-homepage-framework-5%402x.png?auto=compress,format&amp;rect=0,0,544,400&amp;w=272&amp;h=200&amp;q=65"
srcset="https://images.prismic.io/ionicframeworkcom/25d29076-9c99-445c-b367-b5a0caba93ae_capacitor-homepage-framework-5%402x.png?auto=compress,format&amp;rect=0,0,544,400&amp;w=272&amp;h=200&amp;q=65 1x, https://images.prismic.io/ionicframeworkcom/25d29076-9c99-445c-b367-b5a0caba93ae_capacitor-homepage-framework-5%402x.png?auto=compress,format&amp;rect=0,0,544,400&amp;w=544&amp;h=400&amp;q=65 2x"
alt="jquery logo tile" class="sc-landing-page" c-id=15.214.3.0></div><div class="ui-col ui-col-6 ui-col-sm-3 sc-landing-page"
c-id=15.215.2.6><img width=272 height=200 loading=lazy src="https://images.prismic.io/ionicframeworkcom/e98c4d54-c893-4596-93c1-d8ff91e77cf8_capacitor-homepage-framework-6%402x.png?auto=compress,format&amp;rect=0,0,544,400&amp;w=272&amp;h=200&amp;q=65"
srcset="https://images.prismic.io/ionicframeworkcom/e98c4d54-c893-4596-93c1-d8ff91e77cf8_capacitor-homepage-framework-6%402x.png?auto=compress,format&amp;rect=0,0,544,400&amp;w=272&amp;h=200&amp;q=65 1x, https://images.prismic.io/ionicframeworkcom/e98c4d54-c893-4596-93c1-d8ff91e77cf8_capacitor-homepage-framework-6%402x.png?auto=compress,format&amp;rect=0,0,544,400&amp;w=544&amp;h=400&amp;q=65 2x"
alt="bootstrap logo tile" class="sc-landing-page" c-id=15.216.3.0></div><div class="ui-col ui-col-6 ui-col-sm-3 sc-landing-page"
c-id=15.217.2.7><img width=272 height=200 loading=lazy src="https://images.prismic.io/ionicframeworkcom/5953b299-f990-4de6-a6f3-22f07f06ab6b_capacitor-homepage-framework-7%402x.png?auto=compress,format&amp;rect=0,0,544,400&amp;w=272&amp;h=200&amp;q=65"
srcset="https://images.prismic.io/ionicframeworkcom/5953b299-f990-4de6-a6f3-22f07f06ab6b_capacitor-homepage-framework-7%402x.png?auto=compress,format&amp;rect=0,0,544,400&amp;w=272&amp;h=200&amp;q=65 1x, https://images.prismic.io/ionicframeworkcom/5953b299-f990-4de6-a6f3-22f07f06ab6b_capacitor-homepage-framework-7%402x.png?auto=compress,format&amp;rect=0,0,544,400&amp;w=544&amp;h=400&amp;q=65 2x"
alt="ionic logo tile" class="sc-landing-page" c-id=15.218.3.0></div><div class="ui-col ui-col-6 ui-col-sm-3 sc-landing-page"
c-id=15.219.2.8><img width=272 height=200 loading=lazy src="https://images.prismic.io/ionicframeworkcom/d4825c81-c366-4b17-93cd-3c5d36934cdf_capacitor-homepage-framework-8%402x.png?auto=compress,format&amp;rect=0,0,544,400&amp;w=272&amp;h=200&amp;q=65"
srcset="https://images.prismic.io/ionicframeworkcom/d4825c81-c366-4b17-93cd-3c5d36934cdf_capacitor-homepage-framework-8%402x.png?auto=compress,format&amp;rect=0,0,544,400&amp;w=272&amp;h=200&amp;q=65 1x, https://images.prismic.io/ionicframeworkcom/d4825c81-c366-4b17-93cd-3c5d36934cdf_capacitor-homepage-framework-8%402x.png?auto=compress,format&amp;rect=0,0,544,400&amp;w=544&amp;h=400&amp;q=65 2x"
alt="material UI logo tile" class="sc-landing-page" c-id=15.220.3.0></div><div class="ui-col ui-col-6 ui-col-sm-3 sc-landing-page"
c-id=15.221.2.9><img width=272 height=200 loading=lazy src="https://images.prismic.io/ionicframeworkcom/16011d76-bb50-445a-88fe-d0f6e1941998_capacitor-homepage-framework-9%402x.png?auto=compress,format&amp;rect=0,0,544,400&amp;w=272&amp;h=200&amp;q=65"
srcset="https://images.prismic.io/ionicframeworkcom/16011d76-bb50-445a-88fe-d0f6e1941998_capacitor-homepage-framework-9%402x.png?auto=compress,format&amp;rect=0,0,544,400&amp;w=272&amp;h=200&amp;q=65 1x, https://images.prismic.io/ionicframeworkcom/16011d76-bb50-445a-88fe-d0f6e1941998_capacitor-homepage-framework-9%402x.png?auto=compress,format&amp;rect=0,0,544,400&amp;w=544&amp;h=400&amp;q=65 2x"
alt="tailwind logo tile" class="sc-landing-page" c-id=15.222.3.0></div><div class="ui-col ui-col-6 ui-col-sm-3 sc-landing-page"
c-id=15.223.2.10><img width=272 height=200 loading=lazy src="https://images.prismic.io/ionicframeworkcom/29899a2b-db6f-43d9-8f33-46121af2ea02_capacitor-homepage-framework-10%402x.png?auto=compress,format&amp;rect=0,0,544,400&amp;w=272&amp;h=200&amp;q=65"
srcset="https://images.prismic.io/ionicframeworkcom/29899a2b-db6f-43d9-8f33-46121af2ea02_capacitor-homepage-framework-10%402x.png?auto=compress,format&amp;rect=0,0,544,400&amp;w=272&amp;h=200&amp;q=65 1x, https://images.prismic.io/ionicframeworkcom/29899a2b-db6f-43d9-8f33-46121af2ea02_capacitor-homepage-framework-10%402x.png?auto=compress,format&amp;rect=0,0,544,400&amp;w=544&amp;h=400&amp;q=65 2x"
alt="framework 7 logo  tile" class="sc-landing-page" c-id=15.224.3.0></div><div class="ui-col ui-col-6 ui-col-sm-3 sc-landing-page"
c-id=15.225.2.11><img width=272 height=200 loading=lazy src="https://images.prismic.io/ionicframeworkcom/712b55ad-34b0-4efe-886e-fd4b4dd9eecb_capacitor-homepage-framework-11%402x.png?auto=compress,format&amp;rect=0,0,544,400&amp;w=272&amp;h=200&amp;q=65"
srcset="https://images.prismic.io/ionicframeworkcom/712b55ad-34b0-4efe-886e-fd4b4dd9eecb_capacitor-homepage-framework-11%402x.png?auto=compress,format&amp;rect=0,0,544,400&amp;w=272&amp;h=200&amp;q=65 1x, https://images.prismic.io/ionicframeworkcom/712b55ad-34b0-4efe-886e-fd4b4dd9eecb_capacitor-homepage-framework-11%402x.png?auto=compress,format&amp;rect=0,0,544,400&amp;w=544&amp;h=400&amp;q=65 2x"
alt="quasar logo tile" class="sc-landing-page" c-id=15.226.3.0></div></div></section><section id=tweets
class="sc-landing-page" c-id=15.227.0.7><div class="ui-container sc-landing-page" c-id=15.228.1.0><div
class="heading-group sc-landing-page" c-id=15.229.2.0><h2 id="h-what-people-are-saying-about-capacitor"
class="ui-heading ui-heading-2 sc-landing-page" c-id=15.230.3.0><!--t.15.231.4.0-->What people are saying
<em class="sc-landing-page" c-id=15.232.4.1><!--t.15.233.5.0-->about Capacitor.</em></h2></div><div
class="tweets sc-landing-page" c-id=15.234.2.1><article class="tweet sc-landing-page" c-id=15.235.3.0><div
class="title-row sc-landing-page" c-id=15.236.4.0><img loading=lazy src="https://images.prismic.io/ionicframeworkcom/fb85f7f6-bebf-41d7-8264-0ba3fed9c4d6_capacitor-homepage-tweets-0%402x.png?auto=compress,format&amp;rect=0,0,80,80&amp;w=40&amp;h=40&amp;q=65"
srcset="https://images.prismic.io/ionicframeworkcom/fb85f7f6-bebf-41d7-8264-0ba3fed9c4d6_capacitor-homepage-tweets-0%402x.png?auto=compress,format&amp;rect=0,0,80,80&amp;w=40&amp;h=40&amp;q=65 1x, https://images.prismic.io/ionicframeworkcom/fb85f7f6-bebf-41d7-8264-0ba3fed9c4d6_capacitor-homepage-tweets-0%402x.png?auto=compress,format&amp;rect=0,0,80,80&amp;w=80&amp;h=80&amp;q=65 2x"
width=40 height=40 alt="Austin Howard Twitter profile picture" class="sc-landing-page" c-id=15.237.5.0><div
class="title sc-landing-page" c-id=15.238.5.1><h3 class="ui-heading ui-heading-5 sc-landing-page" c-id=15.239.6.0><!--t.15.240.7.0-->Austin Howard</h3><p
class="ui-paragraph ui-paragraph-6 ui-paragraph--body sc-landing-page" c-id=15.241.6.1><!--t.15.242.7.0-->@a_howard8</p></div><svg
width=16 height=13 viewBox="0 0 16 13" fill=none xmlns="http://www.w3.org/2000/svg" class="sc-landing-page"
c-id=15.243.5.2><path d="M16 1.54036C15.41 1.80104 14.7794 1.97708 14.1149 2.05833C14.793 1.65208 15.3151 1.00885 15.5592 0.24375C14.9252 0.619531 14.2234 0.89375 13.474 1.03932C12.8739 0.399479 12.0195 0 11.0769 0C9.26298 0 7.79487 1.46927 7.79487 3.28047C7.79487 3.53776 7.822 3.78828 7.87963 4.02865C5.15024 3.89323 2.72939 2.58646 1.1121 0.599219C0.830685 1.08333 0.667938 1.6487 0.667938 2.24792C0.667938 3.38542 1.25111 4.39089 2.13266 4.97995C1.59017 4.96641 1.08159 4.81745 0.640814 4.57031V4.61094C0.640814 6.20208 1.77326 7.52578 3.27527 7.82708C3.00064 7.90156 2.70905 7.94219 2.41068 7.94219C2.20047 7.94219 1.99364 7.92188 1.7936 7.88125C2.21064 9.18464 3.42445 10.1326 4.86205 10.1596C3.73978 11.0398 2.32253 11.5646 0.783217 11.5646C0.518754 11.5646 0.257682 11.5477 0 11.5172C1.44776 12.4583 3.17355 13 5.02479 13C11.0701 13 14.3725 7.99974 14.3725 3.66302C14.3725 3.52083 14.3691 3.37865 14.3624 3.23984C15.0032 2.77604 15.5592 2.20052 16 1.54036Z"
fill=#1DA1F2 class="sc-landing-page" c-id=15.244.6.0></path></svg></div><p class="content ui-paragraph ui-paragraph-4 ui-paragraph--body sc-landing-page"
c-id=15.245.4.1><!--t.15.246.5.0-->I’m reallllyyyy digging capacitor 👀</p></article><article class="tweet sc-landing-page"
c-id=15.247.3.1><div class="title-row sc-landing-page" c-id=15.248.4.0><img loading=lazy src="https://images.prismic.io/ionicframeworkcom/f8f66de5-0c84-438a-9be7-ccaf636ea445_capacitor-homepage-tweets-1%402x.png?auto=compress,format&amp;rect=0,0,80,80&amp;w=40&amp;h=40&amp;q=65"
srcset="https://images.prismic.io/ionicframeworkcom/f8f66de5-0c84-438a-9be7-ccaf636ea445_capacitor-homepage-tweets-1%402x.png?auto=compress,format&amp;rect=0,0,80,80&amp;w=40&amp;h=40&amp;q=65 1x, https://images.prismic.io/ionicframeworkcom/f8f66de5-0c84-438a-9be7-ccaf636ea445_capacitor-homepage-tweets-1%402x.png?auto=compress,format&amp;rect=0,0,80,80&amp;w=80&amp;h=80&amp;q=65 2x"
width=40 height=40 alt="Angular Twitter profile picture" class="sc-landing-page" c-id=15.249.5.0><div
class="title sc-landing-page" c-id=15.250.5.1><h3 class="ui-heading ui-heading-5 sc-landing-page" c-id=15.251.6.0><!--t.15.252.7.0-->Angular</h3><p
class="ui-paragraph ui-paragraph-6 ui-paragraph--body sc-landing-page" c-id=15.253.6.1><!--t.15.254.7.0-->@angular</p></div><svg
width=16 height=13 viewBox="0 0 16 13" fill=none xmlns="http://www.w3.org/2000/svg" class="sc-landing-page"
c-id=15.255.5.2><path d="M16 1.54036C15.41 1.80104 14.7794 1.97708 14.1149 2.05833C14.793 1.65208 15.3151 1.00885 15.5592 0.24375C14.9252 0.619531 14.2234 0.89375 13.474 1.03932C12.8739 0.399479 12.0195 0 11.0769 0C9.26298 0 7.79487 1.46927 7.79487 3.28047C7.79487 3.53776 7.822 3.78828 7.87963 4.02865C5.15024 3.89323 2.72939 2.58646 1.1121 0.599219C0.830685 1.08333 0.667938 1.6487 0.667938 2.24792C0.667938 3.38542 1.25111 4.39089 2.13266 4.97995C1.59017 4.96641 1.08159 4.81745 0.640814 4.57031V4.61094C0.640814 6.20208 1.77326 7.52578 3.27527 7.82708C3.00064 7.90156 2.70905 7.94219 2.41068 7.94219C2.20047 7.94219 1.99364 7.92188 1.7936 7.88125C2.21064 9.18464 3.42445 10.1326 4.86205 10.1596C3.73978 11.0398 2.32253 11.5646 0.783217 11.5646C0.518754 11.5646 0.257682 11.5477 0 11.5172C1.44776 12.4583 3.17355 13 5.02479 13C11.0701 13 14.3725 7.99974 14.3725 3.66302C14.3725 3.52083 14.3691 3.37865 14.3624 3.23984C15.0032 2.77604 15.5592 2.20052 16 1.54036Z"
fill=#1DA1F2 class="sc-landing-page" c-id=15.256.6.0></path></svg></div><p class="content ui-paragraph ui-paragraph-4 ui-paragraph--body sc-landing-page"
c-id=15.257.4.1><!--t.15.258.5.0-->Did you know <a href="https://twitter.com/capacitorjs" target=_blank
rel=noopener class="sc-landing-page" c-id=15.259.5.1><!--t.15.260.6.0-->@capacitorjs</a><!--t.15.261.5.2--> shows how to give your
<a href="https://twitter.com/search?q=%23Angular&amp;src=typeahead_click" target=_blank
rel=noopener class="sc-landing-page" c-id=15.262.5.3><!--t.15.263.6.0-->#Angular</a><!--t.15.264.5.4--> app access to mobile APIs and a presence in app stores?</p></article><article
class="tweet sc-landing-page" c-id=15.265.3.2><div class="title-row sc-landing-page" c-id=15.266.4.0><img
loading=lazy src="https://images.prismic.io/ionicframeworkcom/5bdb1bb4-cf8d-4efa-90e2-b35bd4a80a3b_capacitor-homepage-tweets-2%402x.png?auto=compress,format&amp;rect=0,0,80,80&amp;w=40&amp;h=40&amp;q=65"
srcset="https://images.prismic.io/ionicframeworkcom/5bdb1bb4-cf8d-4efa-90e2-b35bd4a80a3b_capacitor-homepage-tweets-2%402x.png?auto=compress,format&amp;rect=0,0,80,80&amp;w=40&amp;h=40&amp;q=65 1x, https://images.prismic.io/ionicframeworkcom/5bdb1bb4-cf8d-4efa-90e2-b35bd4a80a3b_capacitor-homepage-tweets-2%402x.png?auto=compress,format&amp;rect=0,0,80,80&amp;w=80&amp;h=80&amp;q=65 2x"
width=40 height=40 alt="Scriptkitty Twitter profile image" class="sc-landing-page" c-id=15.267.5.0><div
class="title sc-landing-page" c-id=15.268.5.1><h3 class="ui-heading ui-heading-5 sc-landing-page" c-id=15.269.6.0><!--t.15.270.7.0-->scriptkitty</h3><p
class="ui-paragraph ui-paragraph-6 ui-paragraph--body sc-landing-page" c-id=15.271.6.1><!--t.15.272.7.0-->@thr0wsException</p></div><svg
width=16 height=13 viewBox="0 0 16 13" fill=none xmlns="http://www.w3.org/2000/svg" class="sc-landing-page"
c-id=15.273.5.2><path d="M16 1.54036C15.41 1.80104 14.7794 1.97708 14.1149 2.05833C14.793 1.65208 15.3151 1.00885 15.5592 0.24375C14.9252 0.619531 14.2234 0.89375 13.474 1.03932C12.8739 0.399479 12.0195 0 11.0769 0C9.26298 0 7.79487 1.46927 7.79487 3.28047C7.79487 3.53776 7.822 3.78828 7.87963 4.02865C5.15024 3.89323 2.72939 2.58646 1.1121 0.599219C0.830685 1.08333 0.667938 1.6487 0.667938 2.24792C0.667938 3.38542 1.25111 4.39089 2.13266 4.97995C1.59017 4.96641 1.08159 4.81745 0.640814 4.57031V4.61094C0.640814 6.20208 1.77326 7.52578 3.27527 7.82708C3.00064 7.90156 2.70905 7.94219 2.41068 7.94219C2.20047 7.94219 1.99364 7.92188 1.7936 7.88125C2.21064 9.18464 3.42445 10.1326 4.86205 10.1596C3.73978 11.0398 2.32253 11.5646 0.783217 11.5646C0.518754 11.5646 0.257682 11.5477 0 11.5172C1.44776 12.4583 3.17355 13 5.02479 13C11.0701 13 14.3725 7.99974 14.3725 3.66302C14.3725 3.52083 14.3691 3.37865 14.3624 3.23984C15.0032 2.77604 15.5592 2.20052 16 1.54036Z"
fill=#1DA1F2 class="sc-landing-page" c-id=15.274.6.0></path></svg></div><p class="content ui-paragraph ui-paragraph-4 ui-paragraph--body sc-landing-page"
c-id=15.275.4.1><!--t.15.276.5.0-->I'm pretty hyped to be honest, from what I've seen so far this will be another major step for establishing web technology as the go-to method for developing cross platform apps ♥</p></article><article
class="tweet sc-landing-page" c-id=15.277.3.3><div class="title-row sc-landing-page" c-id=15.278.4.0><img
loading=lazy src="https://images.prismic.io/ionicframeworkcom/51fcbb2f-575a-46e3-af18-9a9d0710b3eb_capacitor-homepage-tweets-3%402x.png?auto=compress,format&amp;rect=0,0,80,80&amp;w=40&amp;h=40&amp;q=65"
srcset="https://images.prismic.io/ionicframeworkcom/51fcbb2f-575a-46e3-af18-9a9d0710b3eb_capacitor-homepage-tweets-3%402x.png?auto=compress,format&amp;rect=0,0,80,80&amp;w=40&amp;h=40&amp;q=65 1x, https://images.prismic.io/ionicframeworkcom/51fcbb2f-575a-46e3-af18-9a9d0710b3eb_capacitor-homepage-tweets-3%402x.png?auto=compress,format&amp;rect=0,0,80,80&amp;w=80&amp;h=80&amp;q=65 2x"
width=40 height=40 alt="Adeniyi Tolulope Twitter profile image" class="sc-landing-page" c-id=15.279.5.0><div
class="title sc-landing-page" c-id=15.280.5.1><h3 class="ui-heading ui-heading-5 sc-landing-page" c-id=15.281.6.0><!--t.15.282.7.0-->Adeniyi Tolulope</h3><p
class="ui-paragraph ui-paragraph-6 ui-paragraph--body sc-landing-page" c-id=15.283.6.1><!--t.15.284.7.0-->@tolutronics</p></div><svg
width=16 height=13 viewBox="0 0 16 13" fill=none xmlns="http://www.w3.org/2000/svg" class="sc-landing-page"
c-id=15.285.5.2><path d="M16 1.54036C15.41 1.80104 14.7794 1.97708 14.1149 2.05833C14.793 1.65208 15.3151 1.00885 15.5592 0.24375C14.9252 0.619531 14.2234 0.89375 13.474 1.03932C12.8739 0.399479 12.0195 0 11.0769 0C9.26298 0 7.79487 1.46927 7.79487 3.28047C7.79487 3.53776 7.822 3.78828 7.87963 4.02865C5.15024 3.89323 2.72939 2.58646 1.1121 0.599219C0.830685 1.08333 0.667938 1.6487 0.667938 2.24792C0.667938 3.38542 1.25111 4.39089 2.13266 4.97995C1.59017 4.96641 1.08159 4.81745 0.640814 4.57031V4.61094C0.640814 6.20208 1.77326 7.52578 3.27527 7.82708C3.00064 7.90156 2.70905 7.94219 2.41068 7.94219C2.20047 7.94219 1.99364 7.92188 1.7936 7.88125C2.21064 9.18464 3.42445 10.1326 4.86205 10.1596C3.73978 11.0398 2.32253 11.5646 0.783217 11.5646C0.518754 11.5646 0.257682 11.5477 0 11.5172C1.44776 12.4583 3.17355 13 5.02479 13C11.0701 13 14.3725 7.99974 14.3725 3.66302C14.3725 3.52083 14.3691 3.37865 14.3624 3.23984C15.0032 2.77604 15.5592 2.20052 16 1.54036Z"
fill=#1DA1F2 class="sc-landing-page" c-id=15.286.6.0></path></svg></div><p class="content ui-paragraph ui-paragraph-4 ui-paragraph--body sc-landing-page"
c-id=15.287.4.1><a href="https://twitter.com/capacitorjs" target=_blank rel=noopener class="sc-landing-page"
c-id=15.288.5.0><!--t.15.289.6.0-->@capacitorjs</a><!--t.15.290.5.1--> has been a great companion this year... with realtime updates.</p></article><article
class="tweet sc-landing-page" c-id=15.291.3.4><div class="title-row sc-landing-page" c-id=15.292.4.0><img
loading=lazy src="https://images.prismic.io/ionicframeworkcom/8d58919e-b174-46eb-990c-a87d4f02f5f4_capacitor-homepage-tweets-4%402x.png?auto=compress,format&amp;rect=0,0,80,80&amp;w=40&amp;h=40&amp;q=65"
srcset="https://images.prismic.io/ionicframeworkcom/8d58919e-b174-46eb-990c-a87d4f02f5f4_capacitor-homepage-tweets-4%402x.png?auto=compress,format&amp;rect=0,0,80,80&amp;w=40&amp;h=40&amp;q=65 1x, https://images.prismic.io/ionicframeworkcom/8d58919e-b174-46eb-990c-a87d4f02f5f4_capacitor-homepage-tweets-4%402x.png?auto=compress,format&amp;rect=0,0,80,80&amp;w=80&amp;h=80&amp;q=65 2x"
width=40 height=40 alt="Guillermo Rauch twitter profile image" class="sc-landing-page" c-id=15.293.5.0><div
class="title sc-landing-page" c-id=15.294.5.1><h3 class="ui-heading ui-heading-5 sc-landing-page" c-id=15.295.6.0><!--t.15.296.7.0-->Guillermo Rauch<svg
xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512" class="sc-landing-page" c-id=15.297.7.1><path
fill=#1DA1F2 d="M512 268c0 17.9-4.3 34.5-12.9 49.7a92 92 0 01-34.6 35.4c.4 2.7.6 6.9.6 12.6 0 27.1-9.1 50.1-27.1 69.1a86.8 86.8 0 01-65.4 28.6 85.6 85.6 0 01-32.6-6.3 99.2 99.2 0 01-34.6 39.7A86 86 0 01256 512a86.8 86.8 0 01-49.7-14.9 97 97 0 01-34.3-40 85.3 85.3 0 01-32.6 6.3 87.8 87.8 0 01-65.7-28.6 96 96 0 01-26.3-81.7 92.7 92.7 0 01-34.6-35.4A100.3 100.3 0 010 268c0-19 4.8-36.5 14.3-52.3a88.1 88.1 0 0138.3-35.1 98.9 98.9 0 01-6.3-34.3 96 96 0 0127.4-69.1A88.1 88.1 0 01172 54.9a99.2 99.2 0 0134.6-39.7A86.7 86.7 0 01256 0c17.9 0 34.4 5.1 49.4 15.1A100 100 0 01340 54.8a85.3 85.3 0 0132.6-6.3c25.5 0 47.3 9.5 65.4 28.6a96.7 96.7 0 0127.1 69.1c0 12.6-1.9 24-5.7 34.3a88.1 88.1 0 0138.3 35.1A100.4 100.4 0 01512 268zm-266.9 77.1l105.7-158.3c2.7-4.2 3.5-8.8 2.6-13.7-1-4.9-3.5-8.8-7.7-11.4a19.5 19.5 0 00-13.7-2.9c-5 .8-9 3.2-12 7.4l-93.1 140-42.9-42.8a17 17 0 00-13.1-5.4c-5 .2-9.3 2-13.1 5.4a17.5 17.5 0 00-5.1 12.9c0 5.1 1.7 9.4 5.1 12.9l58.9 58.9 2.9 2.3c3.4 2.3 6.9 3.4 10.3 3.4 6.7-.1 11.8-2.9 15.2-8.7z"
class="sc-landing-page" c-id=15.298.8.0></path></svg></h3><p class="ui-paragraph ui-paragraph-6 ui-paragraph--body sc-landing-page"
c-id=15.299.6.1><!--t.15.300.7.0-->@rauchg</p></div><svg width=16 height=13 viewBox="0 0 16 13" fill=none
xmlns="http://www.w3.org/2000/svg" class="sc-landing-page" c-id=15.301.5.2><path d="M16 1.54036C15.41 1.80104 14.7794 1.97708 14.1149 2.05833C14.793 1.65208 15.3151 1.00885 15.5592 0.24375C14.9252 0.619531 14.2234 0.89375 13.474 1.03932C12.8739 0.399479 12.0195 0 11.0769 0C9.26298 0 7.79487 1.46927 7.79487 3.28047C7.79487 3.53776 7.822 3.78828 7.87963 4.02865C5.15024 3.89323 2.72939 2.58646 1.1121 0.599219C0.830685 1.08333 0.667938 1.6487 0.667938 2.24792C0.667938 3.38542 1.25111 4.39089 2.13266 4.97995C1.59017 4.96641 1.08159 4.81745 0.640814 4.57031V4.61094C0.640814 6.20208 1.77326 7.52578 3.27527 7.82708C3.00064 7.90156 2.70905 7.94219 2.41068 7.94219C2.20047 7.94219 1.99364 7.92188 1.7936 7.88125C2.21064 9.18464 3.42445 10.1326 4.86205 10.1596C3.73978 11.0398 2.32253 11.5646 0.783217 11.5646C0.518754 11.5646 0.257682 11.5477 0 11.5172C1.44776 12.4583 3.17355 13 5.02479 13C11.0701 13 14.3725 7.99974 14.3725 3.66302C14.3725 3.52083 14.3691 3.37865 14.3624 3.23984C15.0032 2.77604 15.5592 2.20052 16 1.54036Z"
fill=#1DA1F2 class="sc-landing-page" c-id=15.302.6.0></path></svg></div><p class="content ui-paragraph ui-paragraph-4 ui-paragraph--body sc-landing-page"
c-id=15.303.4.1><!--t.15.304.5.0-->Amazing that this is <a href="https://twitter.com/vercel" target=_blank
rel=noopener class="sc-landing-page" c-id=15.305.5.1><!--t.15.306.6.0-->@vercel</a><!--t.15.307.5.2--> Next.js +
<a href="https://twitter.com/tailwindcss" target=_blank rel=noopener class="sc-landing-page"
c-id=15.308.5.3><!--t.15.309.6.0-->@tailwindcss</a><!--t.15.310.5.4--> + <a href="https://twitter.com/capacitorjs"
target=_blank rel=noopener class="sc-landing-page" c-id=15.311.5.5><!--t.15.312.6.0-->@capacitorjs</a><!--t.15.313.5.6--> 🤯</p></article><article
class="tweet sc-landing-page" c-id=15.314.3.5><div class="title-row sc-landing-page" c-id=15.315.4.0><img
loading=lazy src="https://images.prismic.io/ionicframeworkcom/1b8cb46a-a104-4764-8a67-ec01ab184778_capacitor-homepage-tweets-5%402x.png?auto=compress,format&amp;rect=0,0,80,80&amp;w=40&amp;h=40&amp;q=65"
srcset="https://images.prismic.io/ionicframeworkcom/1b8cb46a-a104-4764-8a67-ec01ab184778_capacitor-homepage-tweets-5%402x.png?auto=compress,format&amp;rect=0,0,80,80&amp;w=40&amp;h=40&amp;q=65 1x, https://images.prismic.io/ionicframeworkcom/1b8cb46a-a104-4764-8a67-ec01ab184778_capacitor-homepage-tweets-5%402x.png?auto=compress,format&amp;rect=0,0,80,80&amp;w=80&amp;h=80&amp;q=65 2x"
width=40 height=40 alt="Carlos Martinez twitter profile image" class="sc-landing-page" c-id=15.316.5.0><div
class="title sc-landing-page" c-id=15.317.5.1><h3 class="ui-heading ui-heading-5 sc-landing-page" c-id=15.318.6.0><!--t.15.319.7.0-->Carlos Martinez</h3><p
class="ui-paragraph ui-paragraph-6 ui-paragraph--body sc-landing-page" c-id=15.320.6.1><!--t.15.321.7.0-->@cmartineztech</p></div><svg
width=16 height=13 viewBox="0 0 16 13" fill=none xmlns="http://www.w3.org/2000/svg" class="sc-landing-page"
c-id=15.322.5.2><path d="M16 1.54036C15.41 1.80104 14.7794 1.97708 14.1149 2.05833C14.793 1.65208 15.3151 1.00885 15.5592 0.24375C14.9252 0.619531 14.2234 0.89375 13.474 1.03932C12.8739 0.399479 12.0195 0 11.0769 0C9.26298 0 7.79487 1.46927 7.79487 3.28047C7.79487 3.53776 7.822 3.78828 7.87963 4.02865C5.15024 3.89323 2.72939 2.58646 1.1121 0.599219C0.830685 1.08333 0.667938 1.6487 0.667938 2.24792C0.667938 3.38542 1.25111 4.39089 2.13266 4.97995C1.59017 4.96641 1.08159 4.81745 0.640814 4.57031V4.61094C0.640814 6.20208 1.77326 7.52578 3.27527 7.82708C3.00064 7.90156 2.70905 7.94219 2.41068 7.94219C2.20047 7.94219 1.99364 7.92188 1.7936 7.88125C2.21064 9.18464 3.42445 10.1326 4.86205 10.1596C3.73978 11.0398 2.32253 11.5646 0.783217 11.5646C0.518754 11.5646 0.257682 11.5477 0 11.5172C1.44776 12.4583 3.17355 13 5.02479 13C11.0701 13 14.3725 7.99974 14.3725 3.66302C14.3725 3.52083 14.3691 3.37865 14.3624 3.23984C15.0032 2.77604 15.5592 2.20052 16 1.54036Z"
fill=#1DA1F2 class="sc-landing-page" c-id=15.323.6.0></path></svg></div><p class="content ui-paragraph ui-paragraph-4 ui-paragraph--body sc-landing-page"
c-id=15.324.4.1><!--t.15.325.5.0-->Yes, It works 😱 deep linking and google native authentication in iOS
<a href="https://twitter.com/capacitorjs"
target=_blank rel=noopener class="sc-landing-page" c-id=15.326.5.1><!--t.15.327.6.0-->@capacitorjs</a></p></article><article
class="tweet sc-landing-page" c-id=15.328.3.6><div class="title-row sc-landing-page" c-id=15.329.4.0><img
loading=lazy src="https://images.prismic.io/ionicframeworkcom/ddfc4e0d-1b71-4d6e-87b4-c2392ed4c9e9_capacitor-homepage-tweets-6%402x.png?auto=compress,format&amp;rect=0,0,80,80&amp;w=40&amp;h=40&amp;q=65"
srcset="https://images.prismic.io/ionicframeworkcom/ddfc4e0d-1b71-4d6e-87b4-c2392ed4c9e9_capacitor-homepage-tweets-6%402x.png?auto=compress,format&amp;rect=0,0,80,80&amp;w=40&amp;h=40&amp;q=65 1x, https://images.prismic.io/ionicframeworkcom/ddfc4e0d-1b71-4d6e-87b4-c2392ed4c9e9_capacitor-homepage-tweets-6%402x.png?auto=compress,format&amp;rect=0,0,80,80&amp;w=80&amp;h=80&amp;q=65 2x"
width=40 height=40 alt="Greg Marine twitter profile image" class="sc-landing-page" c-id=15.330.5.0><div
class="title sc-landing-page" c-id=15.331.5.1><h3 class="ui-heading ui-heading-5 sc-landing-page" c-id=15.332.6.0><!--t.15.333.7.0-->Greg Marine</h3><p
class="ui-paragraph ui-paragraph-6 ui-paragraph--body sc-landing-page" c-id=15.334.6.1><!--t.15.335.7.0-->@gregmarine</p></div><svg
width=16 height=13 viewBox="0 0 16 13" fill=none xmlns="http://www.w3.org/2000/svg" class="sc-landing-page"
c-id=15.336.5.2><path d="M16 1.54036C15.41 1.80104 14.7794 1.97708 14.1149 2.05833C14.793 1.65208 15.3151 1.00885 15.5592 0.24375C14.9252 0.619531 14.2234 0.89375 13.474 1.03932C12.8739 0.399479 12.0195 0 11.0769 0C9.26298 0 7.79487 1.46927 7.79487 3.28047C7.79487 3.53776 7.822 3.78828 7.87963 4.02865C5.15024 3.89323 2.72939 2.58646 1.1121 0.599219C0.830685 1.08333 0.667938 1.6487 0.667938 2.24792C0.667938 3.38542 1.25111 4.39089 2.13266 4.97995C1.59017 4.96641 1.08159 4.81745 0.640814 4.57031V4.61094C0.640814 6.20208 1.77326 7.52578 3.27527 7.82708C3.00064 7.90156 2.70905 7.94219 2.41068 7.94219C2.20047 7.94219 1.99364 7.92188 1.7936 7.88125C2.21064 9.18464 3.42445 10.1326 4.86205 10.1596C3.73978 11.0398 2.32253 11.5646 0.783217 11.5646C0.518754 11.5646 0.257682 11.5477 0 11.5172C1.44776 12.4583 3.17355 13 5.02479 13C11.0701 13 14.3725 7.99974 14.3725 3.66302C14.3725 3.52083 14.3691 3.37865 14.3624 3.23984C15.0032 2.77604 15.5592 2.20052 16 1.54036Z"
fill=#1DA1F2 class="sc-landing-page" c-id=15.337.6.0></path></svg></div><p class="content ui-paragraph ui-paragraph-4 ui-paragraph--body sc-landing-page"
c-id=15.338.4.1><!--t.15.339.5.0-->One of the nice things about Capacitor is that you don’t have to use Ionic. I personally love Ionic and use it for UI components. But it isn’t required for Capacitor 😊</p></article><article
class="tweet sc-landing-page" c-id=15.340.3.7><div class="title-row sc-landing-page" c-id=15.341.4.0><img
loading=lazy src="https://images.prismic.io/ionicframeworkcom/34a9f966-8ab1-4412-9319-db7713080d76_capacitor-homepage-tweets-7%402x.png?auto=compress,format&amp;rect=0,0,80,80&amp;w=40&amp;h=40&amp;q=65"
srcset="https://images.prismic.io/ionicframeworkcom/34a9f966-8ab1-4412-9319-db7713080d76_capacitor-homepage-tweets-7%402x.png?auto=compress,format&amp;rect=0,0,80,80&amp;w=40&amp;h=40&amp;q=65 1x, https://images.prismic.io/ionicframeworkcom/34a9f966-8ab1-4412-9319-db7713080d76_capacitor-homepage-tweets-7%402x.png?auto=compress,format&amp;rect=0,0,80,80&amp;w=80&amp;h=80&amp;q=65 2x"
width=40 height=40 alt="Jacob Clark twitter profile image" class="sc-landing-page" c-id=15.342.5.0><div
class="title sc-landing-page" c-id=15.343.5.1><h3 class="ui-heading ui-heading-5 sc-landing-page" c-id=15.344.6.0><!--t.15.345.7.0-->Jacob Clark</h3><p
class="ui-paragraph ui-paragraph-6 ui-paragraph--body sc-landing-page" c-id=15.346.6.1><!--t.15.347.7.0-->@imjacobclark</p></div><svg
width=16 height=13 viewBox="0 0 16 13" fill=none xmlns="http://www.w3.org/2000/svg" class="sc-landing-page"
c-id=15.348.5.2><path d="M16 1.54036C15.41 1.80104 14.7794 1.97708 14.1149 2.05833C14.793 1.65208 15.3151 1.00885 15.5592 0.24375C14.9252 0.619531 14.2234 0.89375 13.474 1.03932C12.8739 0.399479 12.0195 0 11.0769 0C9.26298 0 7.79487 1.46927 7.79487 3.28047C7.79487 3.53776 7.822 3.78828 7.87963 4.02865C5.15024 3.89323 2.72939 2.58646 1.1121 0.599219C0.830685 1.08333 0.667938 1.6487 0.667938 2.24792C0.667938 3.38542 1.25111 4.39089 2.13266 4.97995C1.59017 4.96641 1.08159 4.81745 0.640814 4.57031V4.61094C0.640814 6.20208 1.77326 7.52578 3.27527 7.82708C3.00064 7.90156 2.70905 7.94219 2.41068 7.94219C2.20047 7.94219 1.99364 7.92188 1.7936 7.88125C2.21064 9.18464 3.42445 10.1326 4.86205 10.1596C3.73978 11.0398 2.32253 11.5646 0.783217 11.5646C0.518754 11.5646 0.257682 11.5477 0 11.5172C1.44776 12.4583 3.17355 13 5.02479 13C11.0701 13 14.3725 7.99974 14.3725 3.66302C14.3725 3.52083 14.3691 3.37865 14.3624 3.23984C15.0032 2.77604 15.5592 2.20052 16 1.54036Z"
fill=#1DA1F2 class="sc-landing-page" c-id=15.349.6.0></path></svg></div><p class="content ui-paragraph ui-paragraph-4 ui-paragraph--body sc-landing-page"
c-id=15.350.4.1><!--t.15.351.5.0-->We blogged about how we use Capacitor to build our 4 Children’s apps at the
<a href="https://twitter.com/bbc"
target=_blank rel=noopener class="sc-landing-page" c-id=15.352.5.1><!--t.15.353.6.0-->@BBC</a></p></article><article
class="tweet sc-landing-page" c-id=15.354.3.8><div class="title-row sc-landing-page" c-id=15.355.4.0><img
loading=lazy src="https://images.prismic.io/ionicframeworkcom/3533f78b-cc83-4fb1-b5f0-9e3240139fbb_capacitor-homepage-tweets-8%402x.png?auto=compress,format&amp;rect=0,0,80,80&amp;w=40&amp;h=40&amp;q=65"
srcset="https://images.prismic.io/ionicframeworkcom/3533f78b-cc83-4fb1-b5f0-9e3240139fbb_capacitor-homepage-tweets-8%402x.png?auto=compress,format&amp;rect=0,0,80,80&amp;w=40&amp;h=40&amp;q=65 1x, https://images.prismic.io/ionicframeworkcom/3533f78b-cc83-4fb1-b5f0-9e3240139fbb_capacitor-homepage-tweets-8%402x.png?auto=compress,format&amp;rect=0,0,80,80&amp;w=80&amp;h=80&amp;q=65 2x"
width=40 height=40 alt="Dayana Jabif twitter profile image" class="sc-landing-page" c-id=15.356.5.0><div
class="title sc-landing-page" c-id=15.357.5.1><h3 class="ui-heading ui-heading-5 sc-landing-page" c-id=15.358.6.0><!--t.15.359.7.0-->Dayana Jabif</h3><p
class="ui-paragraph ui-paragraph-6 ui-paragraph--body sc-landing-page" c-id=15.360.6.1><!--t.15.361.7.0-->@dayujabif</p></div><svg
width=16 height=13 viewBox="0 0 16 13" fill=none xmlns="http://www.w3.org/2000/svg" class="sc-landing-page"
c-id=15.362.5.2><path d="M16 1.54036C15.41 1.80104 14.7794 1.97708 14.1149 2.05833C14.793 1.65208 15.3151 1.00885 15.5592 0.24375C14.9252 0.619531 14.2234 0.89375 13.474 1.03932C12.8739 0.399479 12.0195 0 11.0769 0C9.26298 0 7.79487 1.46927 7.79487 3.28047C7.79487 3.53776 7.822 3.78828 7.87963 4.02865C5.15024 3.89323 2.72939 2.58646 1.1121 0.599219C0.830685 1.08333 0.667938 1.6487 0.667938 2.24792C0.667938 3.38542 1.25111 4.39089 2.13266 4.97995C1.59017 4.96641 1.08159 4.81745 0.640814 4.57031V4.61094C0.640814 6.20208 1.77326 7.52578 3.27527 7.82708C3.00064 7.90156 2.70905 7.94219 2.41068 7.94219C2.20047 7.94219 1.99364 7.92188 1.7936 7.88125C2.21064 9.18464 3.42445 10.1326 4.86205 10.1596C3.73978 11.0398 2.32253 11.5646 0.783217 11.5646C0.518754 11.5646 0.257682 11.5477 0 11.5172C1.44776 12.4583 3.17355 13 5.02479 13C11.0701 13 14.3725 7.99974 14.3725 3.66302C14.3725 3.52083 14.3691 3.37865 14.3624 3.23984C15.0032 2.77604 15.5592 2.20052 16 1.54036Z"
fill=#1DA1F2 class="sc-landing-page" c-id=15.363.6.0></path></svg></div><p class="content ui-paragraph ui-paragraph-4 ui-paragraph--body sc-landing-page"
c-id=15.364.4.1><!--t.15.365.5.0-->I still can't believe how easy is to turn an <a href="https://twitter.com/Ionicframework"
target=_blank rel=noopener class="sc-landing-page" c-id=15.366.5.1><!--t.15.367.6.0-->@Ionicframework</a><!--t.15.368.5.2--> app into a native iOS app using
<a href="https://twitter.com/capacitorjs" target=_blank rel=noopener
class="sc-landing-page" c-id=15.369.5.3><!--t.15.370.6.0-->@capacitorjs</a><!--t.15.371.5.4--> 🤯</p></article><article
class="tweet sc-landing-page" c-id=15.372.3.9><div class="title-row sc-landing-page" c-id=15.373.4.0><img
loading=lazy src="https://images.prismic.io/ionicframeworkcom/03945ca4-1803-486c-b434-21a755acd6d7_capacitor-homepage-tweets-9%402x.png?auto=compress,format&amp;rect=0,0,80,80&amp;w=40&amp;h=40&amp;q=65"
srcset="https://images.prismic.io/ionicframeworkcom/03945ca4-1803-486c-b434-21a755acd6d7_capacitor-homepage-tweets-9%402x.png?auto=compress,format&amp;rect=0,0,80,80&amp;w=40&amp;h=40&amp;q=65 1x, https://images.prismic.io/ionicframeworkcom/03945ca4-1803-486c-b434-21a755acd6d7_capacitor-homepage-tweets-9%402x.png?auto=compress,format&amp;rect=0,0,80,80&amp;w=80&amp;h=80&amp;q=65 2x"
width=40 height=40 alt="Leo twitter profile image" class="sc-landing-page" c-id=15.374.5.0><div class="title sc-landing-page"
c-id=15.375.5.1><h3 class="ui-heading ui-heading-5 sc-landing-page" c-id=15.376.6.0><!--t.15.377.7.0-->Leo</h3><p
class="ui-paragraph ui-paragraph-6 ui-paragraph--body sc-landing-page" c-id=15.378.6.1><!--t.15.379.7.0-->@creativiii</p></div><svg
width=16 height=13 viewBox="0 0 16 13" fill=none xmlns="http://www.w3.org/2000/svg" class="sc-landing-page"
c-id=15.380.5.2><path d="M16 1.54036C15.41 1.80104 14.7794 1.97708 14.1149 2.05833C14.793 1.65208 15.3151 1.00885 15.5592 0.24375C14.9252 0.619531 14.2234 0.89375 13.474 1.03932C12.8739 0.399479 12.0195 0 11.0769 0C9.26298 0 7.79487 1.46927 7.79487 3.28047C7.79487 3.53776 7.822 3.78828 7.87963 4.02865C5.15024 3.89323 2.72939 2.58646 1.1121 0.599219C0.830685 1.08333 0.667938 1.6487 0.667938 2.24792C0.667938 3.38542 1.25111 4.39089 2.13266 4.97995C1.59017 4.96641 1.08159 4.81745 0.640814 4.57031V4.61094C0.640814 6.20208 1.77326 7.52578 3.27527 7.82708C3.00064 7.90156 2.70905 7.94219 2.41068 7.94219C2.20047 7.94219 1.99364 7.92188 1.7936 7.88125C2.21064 9.18464 3.42445 10.1326 4.86205 10.1596C3.73978 11.0398 2.32253 11.5646 0.783217 11.5646C0.518754 11.5646 0.257682 11.5477 0 11.5172C1.44776 12.4583 3.17355 13 5.02479 13C11.0701 13 14.3725 7.99974 14.3725 3.66302C14.3725 3.52083 14.3691 3.37865 14.3624 3.23984C15.0032 2.77604 15.5592 2.20052 16 1.54036Z"
fill=#1DA1F2 class="sc-landing-page" c-id=15.381.6.0></path></svg></div><p class="content ui-paragraph ui-paragraph-4 ui-paragraph--body sc-landing-page"
c-id=15.382.4.1><!--t.15.383.5.0-->I've tried React Native but coming from web dev the DX is such a step down. Give
<a href="https://twitter.com/capacitorjs"
target=_blank rel=noopener class="sc-landing-page" c-id=15.384.5.1><!--t.15.385.6.0-->@capacitorjs</a><!--t.15.386.5.2--> a go if you're building apps 👀</p></article><article
class="tweet sc-landing-page" c-id=15.387.3.10><div class="title-row sc-landing-page" c-id=15.388.4.0><img
loading=lazy src="https://images.prismic.io/ionicframeworkcom/42a15dd9-832f-4929-b3fb-457b5578db67_capacitor-homepage-tweets-10%402x.png?auto=compress,format&amp;rect=0,0,80,80&amp;w=40&amp;h=40&amp;q=65"
srcset="https://images.prismic.io/ionicframeworkcom/42a15dd9-832f-4929-b3fb-457b5578db67_capacitor-homepage-tweets-10%402x.png?auto=compress,format&amp;rect=0,0,80,80&amp;w=40&amp;h=40&amp;q=65 1x, https://images.prismic.io/ionicframeworkcom/42a15dd9-832f-4929-b3fb-457b5578db67_capacitor-homepage-tweets-10%402x.png?auto=compress,format&amp;rect=0,0,80,80&amp;w=80&amp;h=80&amp;q=65 2x"
width=40 height=40 alt="Tim S Twitter profile picture" class="sc-landing-page" c-id=15.389.5.0><div class="title sc-landing-page"
c-id=15.390.5.1><h3 class="ui-heading ui-heading-5 sc-landing-page" c-id=15.391.6.0><!--t.15.392.7.0-->Tim S</h3><p
class="ui-paragraph ui-paragraph-6 ui-paragraph--body sc-landing-page" c-id=15.393.6.1><!--t.15.394.7.0-->@tdawgpharaoh</p></div><svg
width=16 height=13 viewBox="0 0 16 13" fill=none xmlns="http://www.w3.org/2000/svg" class="sc-landing-page"
c-id=15.395.5.2><path d="M16 1.54036C15.41 1.80104 14.7794 1.97708 14.1149 2.05833C14.793 1.65208 15.3151 1.00885 15.5592 0.24375C14.9252 0.619531 14.2234 0.89375 13.474 1.03932C12.8739 0.399479 12.0195 0 11.0769 0C9.26298 0 7.79487 1.46927 7.79487 3.28047C7.79487 3.53776 7.822 3.78828 7.87963 4.02865C5.15024 3.89323 2.72939 2.58646 1.1121 0.599219C0.830685 1.08333 0.667938 1.6487 0.667938 2.24792C0.667938 3.38542 1.25111 4.39089 2.13266 4.97995C1.59017 4.96641 1.08159 4.81745 0.640814 4.57031V4.61094C0.640814 6.20208 1.77326 7.52578 3.27527 7.82708C3.00064 7.90156 2.70905 7.94219 2.41068 7.94219C2.20047 7.94219 1.99364 7.92188 1.7936 7.88125C2.21064 9.18464 3.42445 10.1326 4.86205 10.1596C3.73978 11.0398 2.32253 11.5646 0.783217 11.5646C0.518754 11.5646 0.257682 11.5477 0 11.5172C1.44776 12.4583 3.17355 13 5.02479 13C11.0701 13 14.3725 7.99974 14.3725 3.66302C14.3725 3.52083 14.3691 3.37865 14.3624 3.23984C15.0032 2.77604 15.5592 2.20052 16 1.54036Z"
fill=#1DA1F2 class="sc-landing-page" c-id=15.396.6.0></path></svg></div><p class="content ui-paragraph ui-paragraph-4 ui-paragraph--body sc-landing-page"
c-id=15.397.4.1><!--t.15.398.5.0-->I am asking myself, how did I not hear about <a href="https://twitter.com/capacitorjs"
target=_blank rel=noopener class="sc-landing-page" c-id=15.399.5.1><!--t.15.400.6.0-->@capacitorjs</a><!--t.15.401.5.2--> until recently. Very nice.</p></article><article
class="tweet sc-landing-page" c-id=15.402.3.11><div class="title-row sc-landing-page" c-id=15.403.4.0><img
loading=lazy src="https://images.prismic.io/ionicframeworkcom/73fd0298-fae8-46e8-b1ec-5c464d0b2beb_capacitor-homepage-tweets-11%402x.png?auto=compress,format&amp;rect=0,0,80,80&amp;w=40&amp;h=40&amp;q=65"
srcset="https://images.prismic.io/ionicframeworkcom/73fd0298-fae8-46e8-b1ec-5c464d0b2beb_capacitor-homepage-tweets-11%402x.png?auto=compress,format&amp;rect=0,0,80,80&amp;w=40&amp;h=40&amp;q=65 1x, https://images.prismic.io/ionicframeworkcom/73fd0298-fae8-46e8-b1ec-5c464d0b2beb_capacitor-homepage-tweets-11%402x.png?auto=compress,format&amp;rect=0,0,80,80&amp;w=80&amp;h=80&amp;q=65 2x"
width=40 height=40 alt="Daniel Rodrigues Twitter profile image" class="sc-landing-page" c-id=15.404.5.0><div
class="title sc-landing-page" c-id=15.405.5.1><h3 class="ui-heading ui-heading-5 sc-landing-page" c-id=15.406.6.0><!--t.15.407.7.0-->Daniel Rodrigues</h3><p
class="ui-paragraph ui-paragraph-6 ui-paragraph--body sc-landing-page" c-id=15.408.6.1><!--t.15.409.7.0-->@inspire_rd</p></div><svg
width=16 height=13 viewBox="0 0 16 13" fill=none xmlns="http://www.w3.org/2000/svg" class="sc-landing-page"
c-id=15.410.5.2><path d="M16 1.54036C15.41 1.80104 14.7794 1.97708 14.1149 2.05833C14.793 1.65208 15.3151 1.00885 15.5592 0.24375C14.9252 0.619531 14.2234 0.89375 13.474 1.03932C12.8739 0.399479 12.0195 0 11.0769 0C9.26298 0 7.79487 1.46927 7.79487 3.28047C7.79487 3.53776 7.822 3.78828 7.87963 4.02865C5.15024 3.89323 2.72939 2.58646 1.1121 0.599219C0.830685 1.08333 0.667938 1.6487 0.667938 2.24792C0.667938 3.38542 1.25111 4.39089 2.13266 4.97995C1.59017 4.96641 1.08159 4.81745 0.640814 4.57031V4.61094C0.640814 6.20208 1.77326 7.52578 3.27527 7.82708C3.00064 7.90156 2.70905 7.94219 2.41068 7.94219C2.20047 7.94219 1.99364 7.92188 1.7936 7.88125C2.21064 9.18464 3.42445 10.1326 4.86205 10.1596C3.73978 11.0398 2.32253 11.5646 0.783217 11.5646C0.518754 11.5646 0.257682 11.5477 0 11.5172C1.44776 12.4583 3.17355 13 5.02479 13C11.0701 13 14.3725 7.99974 14.3725 3.66302C14.3725 3.52083 14.3691 3.37865 14.3624 3.23984C15.0032 2.77604 15.5592 2.20052 16 1.54036Z"
fill=#1DA1F2 class="sc-landing-page" c-id=15.411.6.0></path></svg></div><p class="content ui-paragraph ui-paragraph-4 ui-paragraph--body sc-landing-page"
c-id=15.412.4.1><!--t.15.413.5.0-->Tried out <a href="https://twitter.com/capacitorjs" target=_blank rel=noopener
class="sc-landing-page" c-id=15.414.5.1><!--t.15.415.6.0-->@capacitorjs</a><!--t.15.416.5.2--> soon after it went stable - amazing! Simple &amp; straight forward.</p></article></div><div
class="bottom sc-landing-page" c-id=15.417.2.2><p class="ui-paragraph ui-paragraph-3 ui-paragraph--body emoji sc-landing-page"
c-id=15.418.3.0><!--t.15.419.4.0-->👋</p><p class="ui-paragraph ui-paragraph-1 ui-paragraph--body sc-landing-page"
c-id=15.420.3.1><!--t.15.421.4.0-->The Capacitor Community growing. <em class="sc-landing-page" c-id=15.422.4.1><!--t.15.423.5.0-->Connect with us and say Hello.</em></p><div
class="links sc-landing-page" c-id=15.424.3.2><a href="https://twitter.com/capacitorjs" target=_blank
class="sc-landing-page" c-id=15.425.4.0><article class="sc-landing-page" c-id=15.426.5.0><img loading=lazy
src="https://images.prismic.io/ionicframeworkcom/315f6fe8-efcd-4142-bd1a-c3f86c7415c6_capacitor-homepage-tweets-12%402x.png?auto=compress,format&amp;q=65"
alt="Twitter icon" class="sc-landing-page" c-id=15.427.6.0><h4 class="ui-heading ui-heading-4 sc-landing-page"
c-id=15.428.6.1><!--t.15.429.7.0-->Follow us on Twitter</h4></article></a><a href="https://github.com/ionic-team/capacitor"
target=_blank class="sc-landing-page" c-id=15.430.4.1><article class="sc-landing-page" c-id=15.431.5.0><img
loading=lazy src="https://images.prismic.io/ionicframeworkcom/b1f72b6d-7dbf-4268-be11-98bfefdd69c4_capacitor-homepage-tweets-13%402x.png?auto=compress,format&amp;q=65"
alt="Github icon" class="sc-landing-page" c-id=15.432.6.0><h4 class="ui-heading ui-heading-4 sc-landing-page"
c-id=15.433.6.1><!--t.15.434.7.0-->Star us on GitHub</h4></article></a><a href="https://forum.ionicframework.com/c/capacitor"
target=_blank class="sc-landing-page" c-id=15.435.4.2><article class="sc-landing-page" c-id=15.436.5.0><img
loading=lazy src="https://images.prismic.io/ionicframeworkcom/baf89aa5-220b-444b-b594-564474231e74_capacitor-homepage-tweets-14%402x.png?auto=compress,format&amp;q=65"
alt="Chat bubble icon" class="sc-landing-page" c-id=15.437.6.0><h4 class="ui-heading ui-heading-4 sc-landing-page"
c-id=15.438.6.1><!--t.15.439.7.0-->Join the Forum</h4></article></a></div></div></div></section><section
id=multisection class="sc-landing-page" c-id=15.440.0.8><div class="ui-container sc-landing-page" c-id=15.441.1.0><div
id=cta class="sc-landing-page" c-id=15.442.2.0><h2 id="h-supercharge-your-app-with-enterprise-grade-solutions"
class="ui-heading ui-heading-2 sc-landing-page" c-id=15.443.3.0><!--t.15.444.4.0-->Supercharge your app with<em
class="sc-landing-page" c-id=15.445.4.1><!--t.15.446.5.0--> enterprise-grade solutions.</em></h2><div
class="wrapper sc-landing-page" c-id=15.447.3.1><div class="card sc-landing-page" c-id=15.448.4.0><img
class="background sc-landing-page" loading=lazy src="https://images.prismic.io/ionicframeworkcom/af9f0c9c-e321-4576-9319-a8f0d9c1d826_capacitor-homepage-cta-0%402x.png?auto=compress,format&amp;rect=0,0,2432,1110&amp;w=1216&amp;h=555&amp;q=65"
srcset="https://images.prismic.io/ionicframeworkcom/af9f0c9c-e321-4576-9319-a8f0d9c1d826_capacitor-homepage-cta-0%402x.png?auto=compress,format&amp;rect=0,0,2432,1110&amp;w=1216&amp;h=555&amp;q=65 1x, https://images.prismic.io/ionicframeworkcom/af9f0c9c-e321-4576-9319-a8f0d9c1d826_capacitor-homepage-cta-0%402x.png?auto=compress,format&amp;rect=0,0,2432,1110&amp;w=2432&amp;h=1110&amp;q=65 2x"
width=1216 height=555 alt="Raised platforms with app icons" c-id=15.449.5.0><div class="heading-group sc-landing-page"
c-id=15.450.5.1><p class="ui-paragraph ui-paragraph-1 ui-paragraph--body sc-landing-page" c-id=15.451.6.0><em
class="sc-landing-page" c-id=15.452.7.0><!--t.15.453.8.0-->Built for enterprise.</em><!--t.15.454.7.1--> Capacitor and Ionic’s full ecosystem of solutions address the performance, security, and deployment needs of enterprise teams building critical apps.</p><button
href="/enterprise" class="ui-button ui-button-lg ui-button-round ui-button-blue ui-button-fill sc-landing-page"
c-id=15.455.6.1><!--t.15.456.7.0-->Learn more <span class="arrow sc-landing-page" c-id=15.457.7.1><!--t.15.458.8.0--> -&gt;</span></button></div></div></div></div><div
id=companies class="sc-landing-page" c-id=15.459.2.1><div class="wrapper sc-landing-page" c-id=15.460.3.0><div
class="image-group first sc-landing-page" c-id=15.461.4.0><img width=33 height=42 loading=lazy src="https://images.prismic.io/ionicframeworkcom/50c2420c-4c24-4f11-9a32-f4a7ca3d0336_capacitor-homepage-companies-0%402x.png?auto=compress,format&amp;q=65"
alt="Nationwide Logo" class="sc-landing-page" c-id=15.462.5.0><img width=31 height=42 loading=lazy src="https://images.prismic.io/ionicframeworkcom/8b7dc819-33d3-4956-8f71-cc1541521f72_capacitor-homepage-companies-1%402x.png?auto=compress,format&amp;q=65"
alt="Target Logo" class="sc-landing-page" c-id=15.463.5.1><img width=32 height=36 loading=lazy src="https://images.prismic.io/ionicframeworkcom/db3e8564-d1db-4761-8375-9b0b3eb08d3a_capacitor-homepage-companies-2%402x.png?auto=compress,format&amp;q=65"
alt="Burger King Logo" class="sc-landing-page" c-id=15.464.5.2><img width=34 height=34 loading=lazy src="https://images.prismic.io/ionicframeworkcom/9548bcc9-021c-44cb-bace-dec55a005f3f_capacitor-homepage-companies-3%402x.png?auto=compress,format&amp;q=65"
alt="Home Depot Logo" class="sc-landing-page" c-id=15.465.5.3></div><div class="image-group second sc-landing-page"
c-id=15.466.4.1><img width=51 height=30 loading=lazy src="https://images.prismic.io/ionicframeworkcom/efdea796-9ff0-4c91-8c60-2d6270395380_capacitor-homepage-companies-4%402x.png?auto=compress,format&amp;q=65"
alt="NBC Logo" class="sc-landing-page" c-id=15.467.5.0><img width=35 height=35 loading=lazy src="https://images.prismic.io/ionicframeworkcom/546bfd08-986e-4b5b-b579-2e4feb92d0fc_capacitor-homepage-companies-5%402x.png?auto=compress,format&amp;q=65"
alt="Microsoft Logo" class="sc-landing-page" c-id=15.468.5.1><img width=58 height=25 loading=lazy src="https://images.prismic.io/ionicframeworkcom/3f84243e-9c48-465f-a6a7-66c6b974dc97_capacitor-homepage-companies-6%402x.png?auto=compress,format&amp;q=65"
alt="Amtrak Logo" class="sc-landing-page" c-id=15.469.5.2><img width=35 height=35 loading=lazy src="https://images.prismic.io/ionicframeworkcom/2a210c8e-f3f0-4ec5-be6b-38a087b17c19_capacitor-homepage-companies-7%402x.png?auto=compress,format&amp;q=65"
alt="GE Logo" class="sc-landing-page" c-id=15.470.5.3></div></div></div><div id="get-started" class="sc-landing-page"
c-id=15.471.2.2><div class="heading-group sc-landing-page" c-id=15.472.3.0><h2 class="ui-heading ui-heading-2 sc-landing-page"
c-id=15.473.4.0><!--t.15.474.5.0-->Ready to start building?</h2><p class="ui-paragraph ui-paragraph-2 ui-paragraph--body sc-landing-page"
c-id=15.475.4.1><!--t.15.476.5.0-->Dive in and create your first Capacitor project today</p></div><div
class="ctas sc-landing-page" c-id=15.477.3.1><a tabindex=0 href="/docs/getting-started" class="ui-button ui-button-lg ui-button-round ui-button-cyan ui-button-fill secondary sc-landing-page"
c-id=15.478.4.0><!--t.15.479.5.0-->Get Started<span class="arrow sc-landing-page" c-id=15.480.5.1><!--t.15.481.6.0--> -&gt;</span></a><a
tabindex=0 href="/docs/plugins" class="ui-button ui-button-lg ui-button-round ui-button-cyan ui-button-light primary sc-landing-page"
c-id=15.482.4.1><!--t.15.483.5.0-->Explore Plugins<span class="arrow sc-landing-page" c-id=15.484.5.1><!--t.15.485.6.0--> -&gt;</span></a></div></div></div></section><pre-footer
class="sc-landing-page sc-pre-footer-h sc-pre-footer-s hydrated" c-id=15.486.0.9 s-id=27><!--r.27--><div
class="squares sc-pre-footer" c-id=27.0.0.0></div><div class="ui-container sc-pre-footer" c-id=27.1.0.1><a
href="/docs/getting-started" class="sc-pre-footer" c-id=27.2.1.0><svg width=56 height=50 fill=none xmlns="http://www.w3.org/2000/svg"
class="sc-pre-footer" c-id=27.3.2.0><path d="M1 1h16.2c2.86 0 5.61 1.12 7.64 3.12A10.6 10.6 0 0128 11.67V49c0-2.12-.85-4.16-2.37-5.66A8.15 8.15 0 0019.9 41H1V1zM55 1H38.8c-2.86 0-5.61 1.12-7.64 3.12A10.6 10.6 0 0028 11.67V49c0-2.12.85-4.16 2.37-5.66A8.15 8.15 0 0136.1 41H55V1z"
stroke=#46B1FF stroke-width=2 stroke-linecap=round stroke-linejoin=round class="sc-pre-footer" c-id=27.4.3.0></path></svg><h4
class="ui-heading ui-heading-4 sc-pre-footer" c-id=27.5.2.1><!--t.27.6.3.0-->Installation Guide <span
class="arrow sc-pre-footer" c-id=27.7.3.1><!--t.27.8.4.0-->-&gt;</span></h4><p class="ui-paragraph ui-paragraph-3 ui-paragraph--body sc-pre-footer"
c-id=27.9.2.2><!--t.27.10.3.0-->Install Capacitor and learn how to start building with it</p></a><a href="/docs/apis"
class="sc-pre-footer" c-id=27.11.1.1><svg width=48 height=50 fill=none xmlns="http://www.w3.org/2000/svg"
class="sc-pre-footer" c-id=27.12.2.0><path d="M47 34.85v-19.7c0-.65-.18-1.28-.51-1.84a3.77 3.77 0 00-1.4-1.35L26.9 1.76a5.91 5.91 0 00-5.78 0L2.9 11.95c-.58.32-1.07.79-1.4 1.35-.33.56-.5 1.19-.51 1.84v19.7c0 .65.18 1.28.51 1.84s.81 1.02 1.4 1.35l18.2 10.2a5.92 5.92 0 005.78 0l18.2-10.2c.59-.33 1.07-.8 1.4-1.35.33-.56.51-1.2.51-1.84z"
stroke=#46B1FF stroke-width=2 stroke-linecap=round stroke-linejoin=round class="sc-pre-footer" c-id=27.13.3.0></path><path
d="M1.6 13.23L24 25.93l22.4-12.7M24 49V25.92" stroke=#46B1FF stroke-width=2 stroke-linecap=round
stroke-linejoin=round class="sc-pre-footer" c-id=27.14.3.1></path></svg><h4 class="ui-heading ui-heading-4 sc-pre-footer"
c-id=27.15.2.1><!--t.27.16.3.0-->Explore Native Plugins <span class="arrow sc-pre-footer" c-id=27.17.3.1><!--t.27.18.4.0-->-&gt;</span></h4><p
class="ui-paragraph ui-paragraph-3 ui-paragraph--body sc-pre-footer" c-id=27.19.2.2><!--t.27.20.3.0-->Explore Native Plugins that are available to all Capacitor apps</p></a></div></pre-footer><capacitor-site-footer
class="sc-landing-page hydrated" c-id=15.487.0.10 s-id=28><!--r.28--><footer c-id=28.0.0.0><div class="ui-container"
c-id=28.1.1.0><div class=newsletter c-id=28.2.2.0><div c-id=28.3.3.0><h4 class="ui-heading ui-heading-4"
c-id=28.4.4.0><!--t.28.5.5.0-->Join our Newsletter</h4><p class="ui-paragraph ui-paragraph-4 ui-paragraph--body"
c-id=28.6.4.1><!--t.28.7.5.0-->Keep up to date with all the latest Capacitor news and updates</p></div><div
class="form-group" id="id-07054099359845916" c-id=28.8.3.1></div></div><div class="ui-grid" c-id=28.9.2.1><div
class="ui-col ui-col-12 ui-col-xs-12 ui-col-sm-4 ui-col-md-6 copyright" c-id=28.10.3.0><img src="/assets/img/logo-white2.png?v=0d5a68a52e"
alt="Capacitor Logo" class=logo width=212 height=40 loading=lazy c-id=28.11.4.0><p c-id=28.12.4.1><!--t.28.13.5.0-->© 2022 Capacitor</p><p
c-id=28.14.4.2><a href="https://ionic.io" c-id=28.15.5.0><!--t.28.16.6.0-->Ionic Open Source</a><!--t.28.17.5.1--> | Released under
<span id=mit c-id=28.18.5.2><!--t.28.19.6.0-->MIT License</span></p></div><div
class="ui-col ui-col-12 ui-col-xs-12 ui-col-sm-8 ui-col-md-6" c-id=28.20.3.1><div class="routes-group"
c-id=28.21.4.0><div c-id=28.22.5.0><h5 class="ui-heading ui-heading-5" c-id=28.23.6.0><!--t.28.24.7.0-->Developers</h5><ul
class=routes c-id=28.25.6.1><li c-id=28.26.7.0><a class="ui-paragraph-4" href="/docs/getting-started"
c-id=28.27.8.0><!--t.28.28.9.0-->Install</a></li><li c-id=28.29.7.1><a class="ui-paragraph-4" href="/docs"
c-id=28.30.8.0><!--t.28.31.9.0-->Docs</a></li><li c-id=28.32.7.2><a class="ui-paragraph-4" href="/docs/apis"
c-id=28.33.8.0><!--t.28.34.9.0-->Plugins</a></li></ul></div><div c-id=28.35.5.1><h5 class="ui-heading ui-heading-5"
c-id=28.36.6.0><!--t.28.37.7.0-->Resources</h5><ul class=routes c-id=28.38.6.1><li c-id=28.39.7.0><a
class="ui-paragraph-4" href="/community" c-id=28.40.8.0><!--t.28.41.9.0-->Community</a></li><li c-id=28.42.7.1><a
class="ui-paragraph-4" href="/blog" c-id=28.43.8.0><!--t.28.44.9.0-->Blog</a></li><li c-id=28.45.7.2><a
class="ui-paragraph-4" href="https://github.com/ionic-team/capacitor/discussions" c-id=28.46.8.0><!--t.28.47.9.0-->Discussions</a></li></ul></div><div
c-id=28.48.5.2><h5 class="ui-heading ui-heading-5" c-id=28.49.6.0><!--t.28.50.7.0-->Connect</h5><ul
class=routes c-id=28.51.6.1><li c-id=28.52.7.0><a class="ui-paragraph-4" href="https://github.com/ionic-team/capacitor"
c-id=28.53.8.0><!--t.28.54.9.0-->GitHub</a></li><li c-id=28.55.7.1><a class="ui-paragraph-4" href="https://twitter.com/capacitorjs"
c-id=28.56.8.0><!--t.28.57.9.0-->Twitter</a></li><li c-id=28.58.7.2><a class="ui-paragraph-4" href="https://ionic.io"
c-id=28.59.8.0><!--t.28.60.9.0-->Ionic</a></li></ul></div></div></div></div></div></footer></capacitor-site-footer></landing-page></div></site-root></capacitor-site>
<script async defer src="https://buttons.github.io/buttons.js"></script>
 <script data-m>window.jQuery=window.jQuery||(()=>({change:()=>{},trigger:()=>{}}));</script>
 <script async defer src="https://buttons.github.io/buttons.js"></script>
  <script type="text/javascript" id="hs-script-loader" async defer src="//js.hs-scripts.com/3776657.js"></script>
  <script src="https://cdn.jsdelivr.net/npm/prismjs@1.21.0/prism.min.js" type="text/javascript"></script>
<script src="//js.hsforms.net/forms/v2.js" type="text/javascript"></script>
<script type="text/javascript" src="//js.hsforms.net/forms/v2.js"></script>
<script src="https://cdn.jsdelivr.net/npm/docsearch.js@2/dist/cdn/docsearch.min.js" type="text/javascript"></script>
<script data-stencil-static=page.state type="application/json">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</script>
</body>
</html>